Page 1 of 1

Fusesmb

Posted: Wed Sep 26, 2007 6:54 pm
by sonofmoog
I have a Linux Mint Cassandra system successfully networked with two other PC's dual-booting XP and Kubuntu. I really like the default Fusesmb install of Mint. Correct me if I'm wrong, but I believe all I needed to do to enable Fusesmb was to check the box in mintConfig / mintDesktop where it asks Do I have a Windows network and do I want automatic browsing.

My problem is Fusesmb is not installed / enabled by default in my Kubuntu systems, and obviously, they don't have mintDesktop. So, my question is, what is mint doing behind the scenes? How can I recreate the steps to enable Fusesmb in Kubuntu?

TIA

Posted: Wed Sep 26, 2007 7:44 pm
by merlwiz79
Once it's installed you should be able to add it in mtab to have after you login.

Code: Select all

fusesmb /home/merlwiz79/Network fuse rw,nosuid,nodev,allow_other,max_read=32768 0 0
Just edit what you need and it should work the same.

Loading Fusesmb

Posted: Thu Sep 27, 2007 6:55 pm
by sonofmoog
Thanks for the reply. What I wound up doing (before posting my question in this forum) was to invoke fusesmb from /etc/profile, like this:

Code: Select all

fusesmb $HOME/Network
This works, and I don't think there's any problem doing this, but I didn't see anything in my Mint /etc/profile, and wondered how Mint did what it did. You've answered that.

Posted: Sun Sep 30, 2007 7:02 am
by Husse
add it in mtab
huh?
I've learned that mtab is a system generated file you don't edit.....
Could you expand on this merlwiz?

Posted: Sun Sep 30, 2007 1:34 pm
by merlwiz79
Husse wrote:
add it in mtab
huh?
I've learned that mtab is a system generated file you don't edit.....
Could you expand on this merlwiz?
This is the line mintDesktop adds to mtab to mount the Network folder for browsing Windows Networks.
I just told sonofmoog to add it to his mtab.
I wouldn't edit anything else in there.

Posted: Mon Oct 01, 2007 7:44 am
by Husse
OK that makes sense - didn't know that
but it's lost at reboot

Posted: Thu Oct 11, 2007 5:33 pm
by merlwiz79
Husse wrote:OK that makes sense - didn't know that
but it's lost at reboot
It does I didn't know that.
Well go a homemade mintDesktop I made for XFCE CE installed in KDE CE.
You can just make a script example networking.sh

Code: Select all

fusesmb $HOME/Network -o allow_other
Save it where you want ie /usr/bin/
Then edit /etc/kde3/kdm/Xstartup mine is called mintDesktop.sh

Code: Select all

#! /bin/sh
# Xstartup - run as root before session starts

PATH="$PATH:/usr/bin/X11"

if [ -e /etc/nologin ]; then
  # always display the nologin message, if possible
  if [ -s /etc/nologin ] && which xmessage > /dev/null 2>&1; then
    xmessage -file /etc/nologin -geometry 640x480
  fi
  if [ "$(id -u)" != "0" ] && \
     ! grep -qs '^ignore-nologin' /etc/kde3/kdm/kdm.options; then
    exit 1
  fi
fi

/usr/lib/linuxmint/mintDisk/mintDisk.py
/usr/lib/linuxmint/mintAssistant/mintAssistant_launcher.sh
/usr/lib/linuxmint/xfcemintDesktop/mintDesktop.sh
if grep -qs '^use-sessreg' /etc/kde3/kdm/kdm.options && \
   which sessreg > /dev/null 2>&1; then
      exec sessreg -a -l "$DISPLAY" -u /var/run/utmp \
                   -h "`echo $DISPLAY | cut -d: -f1`" "$USER"
      # NOTREACHED
fi

Posted: Fri Oct 12, 2007 5:46 am
by Husse
Nice

yes mtab is really reserved for the system - you are not supposed to edit it :D