Opening fusesmb shares

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
davidiwharper
Level 1
Level 1
Posts: 3
Joined: Wed Sep 26, 2007 7:35 pm

Opening fusesmb shares

Post by davidiwharper » Wed Sep 26, 2007 7:48 pm

Hello,

First of all let me say that I am very impressed with LinuxMint! Congratulations to everyone who has worked on it! I would give you a cool smilie but there aren't any particularly good ones installed :(

Anyway, on to my question.

I have successfully browsed my network with nautilus. It works well. However, some applications (Totem, Amarok, Firefox) don't understand the Gnome network shares, and thus I can't connect to my files without using the fusesmb ~/Network folder.

Unfortunately, when I go to browse my network I can see two of my three computers (which is a bit weird, but anyhow...) and all the shares on said two computers, however when I go to connect to the shares I get an error:
The folder contents could not be displayed.

You do not have the permissions necessary to view the contents of "David_Docs".
Is there any way I can update Mint with my Windows username and password so I can connect to my shares?

Thanks!

wa2n
Level 1
Level 1
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Post by wa2n » Thu Sep 27, 2007 4:19 am

Try to type
smb://your_workgroup/computer_name
on file location (I've tried this on totem movie player).
Maybe it can help a little.

User avatar
sonofmoog
Level 1
Level 1
Posts: 8
Joined: Wed Sep 26, 2007 4:41 pm

Opening networked shares

Post by sonofmoog » Thu Sep 27, 2007 9:36 am

I had a very similar problem, involving EasyTag, namely, it wouldn't show network shares. On the EasyTag Preferences menu there is an item labeled Show Hidden Files When I checked it, all shares were visible and available.

Since I had deleted files on the network, I had a .trash folder on that share. This is a system folder hidden by default, and that what was causing my problem.

I'd suggest looking for a similar option in the preferences of any application you use over the network. A more drastic solution might be to rename / delete those folders, if you don't need them, but I wouldn't recommend it.

HTH

davidiwharper
Level 1
Level 1
Posts: 3
Joined: Wed Sep 26, 2007 7:35 pm

Post by davidiwharper » Mon Oct 01, 2007 1:28 am

Thanks for the tips guys, but neither of these solutions is very helpful.

Any more suggestions?

wa2n
Level 1
Level 1
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Post by wa2n » Mon Oct 01, 2007 2:10 am

The problem might be on your ~/.smb/fusesmb.conf. I had a similar problem with you, and I did this (on terminal):
$ sudo gedit /home/your_home/.smb/fusesmb.conf (enter)
save and exit
$ fusesmb.cache (enter)

Before you edit your fusesmb.conf, check the manual first : $ man fusesmb.conf.

Here is my fusesmb.conf detail :
[global]
; Default username and password
username=username1
password=password1
interval=10

; Share-specific settings
[/SERVER]
username=username2
password=password2

davidiwharper
Level 1
Level 1
Posts: 3
Joined: Wed Sep 26, 2007 7:35 pm

Post by davidiwharper » Mon Oct 01, 2007 3:05 am

Thank you, that did the trick!

Post Reply

Return to “Ethernet”