Page 1 of 1

Interacting with a Windows Home Network Via SAMBA

Posted: Fri Jan 05, 2007 12:15 am
by MDT
Ok,
I have SAMBA set up, and I can type in a workgroup/station (IE: MSHOME/DESKTOP/SHAREDFOLDERNAME) and access a Windows PC from my Mint PC. However, I can't navigate to it through SAMBA. SAMBA shows the Workgroup, but shows it as a page (only way I can describe it, the icon I mean) and when I double click on it I get an error that says it can't open an object of that type.
I cannot get into my Mint machine from the windows machines either. They see it on the workgroup, but when I click on it it asks for a user and password, and when I use my Mint Linux login/password it fails. I also can't find anyplace to setup a Samba userid/password (which I'd done on a diff distro, but that never worked either).

FInally,
I have a shared printer on the windows network (which I need to keep connected to a windows machine due to layout in the house). I would like to print to the printer from the Mint machine (it's a shared printer on the workgroup, and all other computers can print to it).

Thank you very much in advance for any and all help. I'll keep looking on the internet, but thought I'd post a question here first as I've gotten good help here so far. As a side note, I love this distro, despite the few problems I've had, it's been much better than any other distro I tried (and I tried about 8 of them). It's also been much less painful than installing XP Home was. ;)

MDT

I know, I should do more research before I bug everyone

Posted: Fri Jan 05, 2007 12:40 am
by MDT
Ok,
Got Samba to work after reading through the forums. Still can't get to the shared printer on the Windows machine, but I can navigate to the windows box now, and vice versa. :) GSAMBAD was what I needed, fixed it right up. I'll see if I can find a solution for the printer, if not, I'll post back that I still need help.

MDT

Whoops, still can't connect to Linux Mint from Windows XP

Posted: Fri Jan 05, 2007 2:40 am
by MDT
Ok,
My bad. I assumed since I was actually seeing the linux mint machine in my network, it was working. However, when I click on it, I get a 'do not have access to this device, ask your local administrator' error. I can connect to the XP machine and the 2000 machine from Mint, however.

I get the following errors when running GSAMBAD, but I don't know if it means anything.
winbindd: no process killed
Restarting samba (winbindd) failed
winbindd: no process killed
Restarting samba (winbindd) failed
winbindd: no process killed
Restarting samba (winbindd) failed
winbindd: no process killed
Restarting samba (winbindd) failed
winbindd: no process killed
Restarting samba (winbindd) failed
root@mint:~# winbindd
Any help would be greatly appreciated. I'm sure its a setting somewhere I'm missing. I'll be happy to put up any settings anyone needs to help me debug this. Thanks...

MDT

Posted: Fri Jan 05, 2007 4:46 pm
by clem
I'm planning to include automatic Samba browsing and sharing as part of the next version of mintDesktop.

Auto Windows Browsing

Posted: Fri Jan 05, 2007 5:46 pm
by MDT
clem wrote:I'm planning to include automatic Samba browsing and sharing as part of the next version of mintDesktop.
Hmmm,
I think a WOOT! would be appropriate. :) Thanks.

MDT

Posted: Sat Jan 06, 2007 1:18 am
by ajt3nc
I would love to help test this at the house and my offices.
Xandros has some good scripts to enable this but I do not care for the rest of the distro.

Posted: Sat Jan 06, 2007 9:47 pm
by clem
Well you can. mintDesktop 1.2 was released and includes automatic Samba browsing.

Clem

Didn't check off SAMBA when initially setting up Shared Fold

Posted: Tue Jan 09, 2007 8:11 pm
by jcoleman
I have no excuse -

I don't know why but I unchecked the box for SAMBA when setting up for shared folders initially. How do I add it in after the fact?

I can't see my shared folders with that computer on my home network

Forgot to update

Posted: Sat Mar 03, 2007 3:29 pm
by MDT
Got Samba to work, sort of, before upgrading to Bianca. So I don't know if the auto-Samba would work or not. I still can't navigate to the Mint machine, but the mint machine can see the entire Windows network and navigate to any file on the system. Also got it using shared printers (where drivers exist, still irritates me my new Cannon laser printer won't work with Linux).

Thanks for the help though.

MDT

Posted: Mon Mar 05, 2007 2:41 pm
by mfab
i also receive problems with my network (windows) share.
did work in bea though, but got lost somewhen during updates in bea and does not work in bianca either.

example: i used to do smb://computername/share and then i would get a box asking me for the name and password (i think there was something like "connect to a server" in the menu where you can go to different places at your pc)

now when i try to do the same i get an error box showing:
"The folder contents could not be displayed.
Sorry, couldn't display all the contents of "Windows Network: computername"."

it is the same when i try to navigate there via the network and workgroup.

any help is greatly appreciated :?

Posted: Thu Mar 15, 2007 6:52 pm
by Lolo Uila
Same problem here.

I can get on-line fine so the network interface seems to be working.

I can see my local network and Windows workgroup. I can see the Windows computers on the workgroup -- but when I try to open any shared resources on those computers I get the same error as above.

Posted: Fri Mar 16, 2007 2:50 am
by Flint
I've got the same problem and message. Any help will be appreciated... :?

Posted: Fri Mar 16, 2007 4:16 am
by Flint
So - I fixed my problem.
I simply "completely remove"ed from Synaptic the following packages:

samba
samba-common
smbclient
smbfs

And then installed them again :)

After this procedure I can browse the other pcs on the network which are running xp

Posted: Sun Mar 18, 2007 11:07 pm
by Lolo Uila
I fixed my problem by renaming my workgroup. I think Linux didn't like the name I have been using for my Windows workgroup. After renaming it to something less objectionable and rebooting the Windows boxes Mint can see them now.

However, the connection speed seems very slow. I've got gigabit wired run at my house and the Linux network info says 1000 Mb/s, but feels like it's running at 10. Anyway to speed things up?