Sharing Files with Windows (SOLVED)

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Sharing Files with Windows (SOLVED)

Post by Fornhamfred »

I have installed LMDE and am able to access all the shared files on my windows xp box but I am unable to access any shared files on my linux box. I can see LDME on the network places but it continually asks for the user name and password which are the same on both boxes.

I have followed altairs how to and added the extra lines to global in smb.conf but the nautilus share option on the files does not work. I have Mint 9 installed and have had no problems with networking.

The main directory I wish to share is a FAT32 partition which is automatically mounted thro fstab. Can anyone suggest what I need to change please.
Last edited by Fornhamfred on Mon Oct 04, 2010 2:03 pm, edited 1 time in total.

Teucca
Level 2
Level 2
Posts: 75
Joined: Sat Sep 26, 2009 3:06 pm
Location: Helsinki (gothenburgh)
Contact:

Re: Sharing Files with Windows

Post by Teucca »

Last edited by Teucca on Sat Apr 09, 2011 5:42 am, edited 2 times in total.
Linux Mint Suomi guide
MINT is an easy, logical, adaptable, inspiring, user-friendly operating system.
The changes are new opportunities
Help Site Instructions

User avatar
Midnighter
Level 6
Level 6
Posts: 1319
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Re: Sharing Files with Windows

Post by Midnighter »

Try user name of "guest", and I think no password, or if that not work, try "guest" again. I had this once, and googling gave me this, and fixed it. This is, of course, using Simple File sharing.
If you accept - and I do - that freedom of speech is important, then you are going to have to defend the indefensible. That means you are going to be defending the right of people to read, or to write, or to say, what you don't say or like or want said.

altair4
Level 19
Level 19
Posts: 9892
Joined: Tue Feb 03, 2009 10:27 am

Re: Sharing Files with Windows

Post by altair4 »

It almost sounds like a permissions problem and not a samba problem. If you don't mind would you post the output of the following commands:

Code: Select all

net usershare info

Code: Select all

sudo net usershare info

Code: Select all

testparm -s

Code: Select all

cat /etc/fstab
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Sharing Files with Windows

Post by Fornhamfred »

Thanks Altair,

No output from the first two

Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
workgroup = MSHOME
server string = %h server (Samba)
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
force user = wilf

[homes]
comment = Home Directories
create mask = 0775
directory mask = 0775
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers



$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=39dce7bc-28c6-4d48-a3e1-b2d48712856e / ext3 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=f5355ad1-6de9-497b-a8d4-e2abe7336d4d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda5 / ext4 rw,errors=remount-ro 0 0
/dev/sda7 /home ext4 rw,errors=remount-ro 0 0
/dev/sdb9 /home/wilf/Data vfat umask=0000,uid=1000,gid=1000,auto,rw,users 0 0

altair4
Level 19
Level 19
Posts: 9892
Joined: Tue Feb 03, 2009 10:27 am

Re: Sharing Files with Windows

Post by altair4 »

I'm now confused by your post. You don't have any nautilus-shares ( net usershare info would have displayed the nautilus-shares ).

You are missing a line in the global section of smb.conf that converts unauthenticated remote users to guests:

Code: Select all

map to guest = bad user
You don't have any explicit classic shares either.

When you say that nautilus-shares don't work do you mean you can create them but you have no access? Or do you mean you're getting an error when you attempt to create them?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Sharing Files with Windows

Post by Fornhamfred »

Sorry to have caused confusion.

The problem I was having was that in Nautilus, right clicking the file I wanted to share bought up the share window but after choosing the share and ok no share was configured.

However having added the line you suggested to smb.conf I am now able to make the share stick in Nautilus and also in windows I can now see the shared printers and files on LMDE.

net usershare now shows:


$ net usershare info
[data]
path=/home/wilf/Data
comment=
usershare_acl=Everyone:F,
guest_ok=n

wilf@LMDE ~ $ sudo net usershare info
[sudo] password for wilf:
wilf@LMDE ~ $

Thanks for your help.

Post Reply

Return to “Ethernet”