Connecting to shared folder from Windows problem

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
baba
Level 1
Level 1
Posts: 36
Joined: Tue Sep 04, 2007 5:08 pm

Connecting to shared folder from Windows problem

Post by baba » Wed Oct 03, 2007 12:43 pm

I have a folder set up for sharing, smb. I am trying to use it from windows, map network drive. I can see the Mint computer, but when I try to connect to the shared folder, I get prompted for a username and password. Nothing I enter here seems to work. Of course i tried my Mint username and password and even windows username and password. Is there a separate username and password for network login?

I also tried connecting from a computer running PCLOS. Same problem, prompts for a username and password.

wa2n
Level 1
Level 1
Posts: 29
Joined: Sun Sep 09, 2007 10:50 pm

Post by wa2n » Thu Oct 04, 2007 12:35 am

It seems like the problem is on your smb.conf. You can check here :
http://www.linuxmint.com/forum/viewtopic.php?t=4974

On terminal :
$ cd /etc/samba
$ sudo cp smb.conf smb.conf-backup
$ sudo gedit smb.conf

The main change is on security=user line, change into security = share
and activate the guest account = nobody line by removing the ";".

save and exit
$ sudo /etc/init.d/samba restart (enter)

baba
Level 1
Level 1
Posts: 36
Joined: Tue Sep 04, 2007 5:08 pm

Post by baba » Thu Oct 04, 2007 2:53 am

wa2n, yes, that's it. I'm still new to this. There are so many settings in so many places. Thanks.

User avatar
eagle
Level 1
Level 1
Posts: 31
Joined: Fri Jul 06, 2007 12:22 am

Post by eagle » Thu Oct 18, 2007 4:02 pm

Great wa2n, thanks for the info. I have always had problems with this, but was always to lazy for figure it out. Lucky I stumbled over this.

Just a note for other noobs like me, make sure that you activate the 'security=user' line by removing the ';', same as wa2n says for the 'guest account = nobody' line.

Post Reply

Return to “Ethernet”