Page 1 of 1

bcmwl5 wifi driver kills ethernet(eth0) port. SOLVED

Posted: Tue Jul 12, 2011 9:08 pm
by frostfire
Info: Dell inspiron e1505 laptop. Linux mint 11. katya. Wifi card is a Minicard wlan 1390. also have eth0 port

Problem: driver needed to activate wifi card is bcmwl5.....when i install the driver and restart wlan0 works fine but the eth0 is not recognized in terminal with the 'ifconfig' or 'iwlist scanning' commands. I can get eth0 to work by uninstalling the driver and restarting.

However i need both connections to work at same time so i can share the network with my desktop. WHAT DO I DO?

I have tried: restarting, reinstallin OS, uninstalling and reinstalling drivers, i tried Ubuntu...had same problem, i have tried different network managers.... but still no luck

more info:
wade@wade-MM061 ~ $ sudo lshw -C network; cat /etc/lsb-release; rfkill list
[sudo] password for wade:
description: Wireless interface
product: BCM4311 802.11b/g WLAN
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0b:00.0
logical name: wlan0
version: 01
serial: 00:1a:92:7f:5d:57
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.56+Broadcom,10/12/2006, 4.100. ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11g
resources: irq:16 memory:efdfc000-efdfffff
*-network UNCLAIMED
description: Ethernet controller
product: BCM4401-B0 100Base-TX
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=64
resources: memory:ef9fe000-ef9fffff
0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

Re: bcmwl5 wifi driver kills ethernet(eth0) port.

Posted: Tue Jul 12, 2011 9:12 pm
by TBABill
Looks like you have Broadcom wired AND wireless. Possibly the install of the wireless driver blacklisted the driver for the wired. You can look in /etc/modprobe.d/blacklist.conf and see what is blacklisted. I think b44 and ssb may be needed so see if they are blacklisted.

Re: bcmwl5 wifi driver kills ethernet(eth0) port.

Posted: Wed Jul 13, 2011 2:07 am
by frostfire
Sorry i dont really understand what that means, or how im supposed to fix it... but when i open the blacklist.conf (read only file) this is what it says:

# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac

Re: bcmwl5 wifi driver kills ethernet(eth0) port.

Posted: Wed Jul 13, 2011 3:15 am
by steev
I think the problem is that your ethernet driver depends on the 'ssb' module, and bcmwl is known to conflict with ssb.

Have your tried using the 'b43' driver for your wifi?
It's supposed to support the bcm4311

b43 requires firmware to work, here are instructions to install it: ... AC8-Debian

Re: bcmwl5 wifi driver kills ethernet(eth0) port.

Posted: Wed Jul 13, 2011 2:03 pm
by frostfire
THANKS!(: this worked, just use b43 instead of bcmwl5...both will activate wifi but the bcml5 also kills eth0.

But i couldnt figure out how to install off that site what i did was install fresh linux mint 10, because 10 comes with sta and b43 prepackaged so it is way easier! now i know both interfaces are working...and i am able to connect laptop to desktop and it says its connected on both ends....however i cannot access internet on desktop. i did the change to 'shared between computers' in edit connections....but still nothing