Page 1 of 1

KDE Frameworks 5 - could it be backported into 17?

Posted: Wed Oct 28, 2015 12:28 pm
by Jedinovice
OK, I know Mint 17 is 'frozen' on the Ubuntu LTS editions and I throughly approve. I also that Plasma 5 is likely to be in 18 but not before - and that gives Plasma several months to further bed in before 18 is started in.

But.. I have run up Kubuntu 15.10 with Plasma 5 in a VM - just barely on my tiny atom machine - and, it's OK, but I'm not wild about it. It's all 2D and tablet/Windows 2 like. Libreoffice does not look nice in the new system. Of course, I haven't played around with customization yet.

Given KDE frameworks is separate from Plasma itself and Kdenlive - which is my only real reason for an eye on Plasma 5 - would work in, say, XFCE with the frameworks… would it be possible to backport QT frameworks 5 into Mint 17.0? Then I wouldn't have to upgrade anything else.

I doubt it for various reasons I can think of but I'm just askin'! :-) I know Cinnamon updates were backported to 13 at one point!
Thanks for info in advance.

Re: KDE Frameworks 5 - could it be backported into 17?

Posted: Thu Oct 29, 2015 3:15 am
by xenopeek
Possibly, probably, but it's not happening on Linux Mint. 17.3 development has just started and the roadmap of things to do is bulging. Afterwards it's on to Cinnamon 3.0 and Linux Mint 18. Besides, this would interest only a small group of Linux Mint 17.x users. Kubuntu used to have it in its backports PPA for Ubuntu 14.04 LTS and you could use that with Linux Mint 17.x, but they have dropped it from the PPA.

In short, if this is something you want it's something you'll have to do :wink: Or upgrade to Linux Mint 18 when it is out.

Re: KDE Frameworks 5 - could it be backported into 17?

Posted: Thu Oct 29, 2015 5:03 am
by Jedinovice
xenopeek wrote:Possibly, probably, but it's not happening on Linux Mint. 17.3 development has just started and the roadmap of things to do is bulging. Afterwards it's on to Cinnamon 3.0 and Linux Mint 18. Besides, this would interest only a small group of Linux Mint 17.x users. Kubuntu used to have it in its backports PPA for Ubuntu 14.04 LTS and you could use that with Linux Mint 17.x, but they have dropped it from the PPA.

In short, if this is something you want it's something you'll have to do :wink: Or upgrade to Linux Mint 18 when it is out.
That's what I figured the info would be! I'm OK about upgrading to 18 when the time comes.
That's why I am testing Plasma 5 under Kubntu!
I'll take a closer look at the customisation options and see if I can make it less 'Windows 2' like.

Thanks Xenopeek!

Re: KDE Frameworks 5 - could it be backported into 17?

Posted: Thu Oct 29, 2015 9:47 am
by Jedinovice
Oh just to clarify...

What I meant was, could the frameworks be installed WITHOUT altering Plasma 4 - as XFCE or Cinnamon in 18 would have to install the frameworks as a dependency for the likes of Kdenlive in 18.

So I wondered if a backport of the frameworks without touching Plasma itself in KDE for 17 was possible?

But, I will take the answer as "no" anyway for reasons already stated.

Thing is... I like the functionality of KDE and I like Kdenlive a lot,,, but Plasma 5 is not winning my heart over.
There's no borders to anything now so Dolphin merges into Libreoffice, for instance. It's not nearly as bad a GNOME 3 and the workflow and functionality is not altered but the visual design is... yeeerk so far.
I was hoping I could get updates to Kdenlive without having to go full on Plasma 5. Oh well.