Disabled Touchpad Is Been Enabled Back After Reboot (xinput)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
dolevsal
Level 1
Level 1
Posts: 3
Joined: Mon Aug 12, 2019 4:26 pm

Disabled Touchpad Is Been Enabled Back After Reboot (xinput)

Post by dolevsal » Mon Aug 12, 2019 4:34 pm

Hi there,

I installed Linux mint 19 on Toshiba satellite with faulty touch screen. I was able to disable it by simple "xinput disable" command however, after restart the change is gone and the faulty touch screen is again enabled.
Would appreciate assistance on which method should i use so this changes will be saved (startup script? If so, example will be awesome)


Thank you in advance!


dolevsal
Level 1
Level 1
Posts: 3
Joined: Mon Aug 12, 2019 4:26 pm

Re: Disable Hardware Is Been Enabled Back After Reboot (xinput)

Post by dolevsal » Mon Aug 12, 2019 4:45 pm

Thank you very much for the quick response.
If that does not work, get the name of your touchscreen with xinput, and add one of the following commands to a startup script:

xinput set-prop [touchscreen id] "Device Enabled" 0
xinput disable [touchscreen id]
Where do i add these two lines? On which file and where can i find it?

The Bright Side
Level 2
Level 2
Posts: 53
Joined: Thu Jul 12, 2018 3:09 pm

Re: Disabled Touchpad Is Been Enabled Back After Reboot (xinput)

Post by The Bright Side » Thu Aug 22, 2019 1:42 am

Hey dolevsal,

I've been struggling with my touchpad on Mint 19.2 as well, experiencing the exact same problem you are.

In fact, no matter what I've tried, the touchpad keeps re-enabling itself randomly and unpredictably when you least expect it.

Here's how you make a startup script with the commands mentioned:

1. Open "Startup Applications"
2. Click on the "+" button to add a new one
3. Select "Custom Command"
4. Paste the command into the "Command" field
5. Write whatever you want in the Name and Description fields

Another option is to install touchpad-indicator:

1. sudo add-apt-repository ppa:atareao/atareao
2. sudo apt update
3. sudo apt install touchpad-indicator

It sits in your notification tray and you can configure it to run at boot, disable the touchpad when it starts, when a mouse is plugged in, while you type and to even keep it disabled should you ever close the indicator.

Yet, the touchpad (in my experience) will still turn itself back on randomly when you don't expect it. I really, really hope they'll fix this bug.

If anybody else has a suggestion, please let us know.

dolevsal
Level 1
Level 1
Posts: 3
Joined: Mon Aug 12, 2019 4:26 pm

Re: Disabled Touchpad Is Been Enabled Back After Reboot (xinput)

Post by dolevsal » Thu Aug 22, 2019 3:36 am

Thank you very much! Yes it is a bug because i already did like you instructed few months ago.

The Bright Side
Level 2
Level 2
Posts: 53
Joined: Thu Jul 12, 2018 3:09 pm

Re: Disabled Touchpad Is Been Enabled Back After Reboot (xinput)

Post by The Bright Side » Fri Aug 23, 2019 2:08 am

To anybody reading this, your solution might be:

Code: Select all

sudo chown -Rc $USER:$USER $HOME
After that, turn off the touchpad in Mouse and Touchpad settings, then reboot.

More info in this thread:
viewtopic.php?f=47&t=300339

I think this worked for me! (but I will keep an eye on it for a few days and report back if there are any more shenanigans.)

Post Reply

Return to “Hardware Support”