Enabling ctrl+alt+backspace[Solved]

Questions and thoughts about present and future editions
Forum rules
Before you post please read this
Post Reply
toehead
Level 1
Level 1
Posts: 2
Joined: Wed Jul 07, 2010 2:33 pm

Enabling ctrl+alt+backspace[Solved]

Post by toehead » Wed Jul 07, 2010 3:37 pm

I did a search and found this:
The key combination Ctrl+Alt+Backspace to kill the X server has been disabled by default as a decision of the upstream Xorg project. You can change the default by adding the following section to your xorg.conf file. If one does not exist, you can create it manually at /etc/X11/xorg.conf using a text editor and Xorg will honor that setting.

Code: Select all
Section "ServerFlags"
Option "DontZap" "false"
EndSection



The Xorg project has changed the default DontZap setting to “true” after complaints from desktop users that accidentally hit Ctrl+Alt+Backspace when trying to type Alt+Backspace, Ctrl+Backspace, or Shift+Backspace, or who had StickyKeys enabled. Ctrl+Alt+Backspace is also a keyboard shortcut for deleting certain expressions in C and Java modes in Emacs.
I have made the xorg.conf file, do I also make a xorg.conf directory within the x11 directory and place the file in there? I am having difficulty placing it in the x11 directory, the permissions for this file are set to read and write. Is this something that needs to be done from the live cd?
Last edited by toehead on Wed Jul 07, 2010 4:03 pm, edited 1 time in total.

User avatar
proxima_centauri
Level 11
Level 11
Posts: 3961
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Enabling ctrl+alt+backspace

Post by proxima_centauri » Wed Jul 07, 2010 3:52 pm

I can believe you can simply enable it by going to Keyboard Preferences, Layout tab -> Options..., Key Sequence to kill the X server. Put a check next to Ctrl+Alt+Backspace.

toehead
Level 1
Level 1
Posts: 2
Joined: Wed Jul 07, 2010 2:33 pm

Re: Enabling ctrl+alt+backspace[Solved]

Post by toehead » Wed Jul 07, 2010 4:02 pm

Thanks for the reply. I checked where you said, it was checked already. Tried the key combination while the system is up and running and it works. Hmmm. Guess I have another post to make now.

Post Reply

Return to “About Mint Editions”