[SOLVED]Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
water
Level 1
Level 1
Posts: 3
Joined: Mon Mar 20, 2017 10:06 pm

[SOLVED]Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Postby water » Mon Mar 20, 2017 10:42 pm

I am new to Linux Mint, and have only networked Windows PCs before. I am trying to mount a folder on a Synology NAS (located on the same network) to Linux Mint. I can mount it manually, but would like to edit fstab so that it auto mounts on startup.

I can't figure out how to correctly type the fstab line of code. I think it has to do with me not understanding how to include login credentials for the Synology NAS.

I have read as much as I can find online about this type of issue, and have not been able to make it work. Here are a few versions I tried, and the error message I received each time.

If I add this line to fstab:
#automount Synology Music

Code: Select all

192.168.0.103:/volume1/Music /home/water/MusicTarget nfs user,rw,hard 0 0


I get this result:
Unable to mount MusicTarget
mount.nfs: access denied by server while mounting 192.168.0.103:/volume1/Music

Which makes sense, as credentials are requested by the Synology when I mount manually.

So if I use this one:
#automount Synology Music w viewable credentials

Code: Select all

192.168.0.103:/volume1/Music /home/water/MusicTarget nfs username=[i]username[/i],password=[i]password[/i],rw,hard 0 0


I get this result:
Unable to mount MusicTarget
mount: only root can mount 192.168.0.103:/volume1/Music on /home/water/MusicTarget

So, if I add this line to fstab including the "user" option:
#automount Synology Music w viewable credentials and user cmd

Code: Select all

192.168.0.103:/volume1/Music /home/water/MusicTarget nfs [i]username[/i]=[i]username[/i],[i]password[/i]=[i]password[/i],rw,hard,user 0 0


I get this result:
Unable to mount MusicTarget
mount.nfs: an incorrect mount option was specified

I'm obviously not understanding this correctly, and any help would be much appreciated.

info on both devices:

Linux Mint System
Kernel: 4.4.0-66-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.2)
Distro: Linux Mint 18.1 Serena

NAS
Synology DS1812+
Last edited by water on Tue Mar 21, 2017 3:40 pm, edited 1 time in total.

User avatar
WharfRat
Level 18
Level 18
Posts: 8440
Joined: Thu Apr 07, 2011 8:15 pm

Re: Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Postby WharfRat » Mon Mar 20, 2017 11:49 pm

Hello water and welcome to the Linux Mint forum :)

It has been a long time since I used nfs, but when using automount Synology Music w viewable credentials are you using sudo mount or plain mount :?:

The error alludes to not having the authority to mount it
mount: only root can mount 192.168.0.103:/volume1/Music on /home/water/MusicTarget


To not have to issue sudo you can add the user fstab option :wink:
Image Image Image

water
Level 1
Level 1
Posts: 3
Joined: Mon Mar 20, 2017 10:06 pm

Re: Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Postby water » Tue Mar 21, 2017 12:17 am

WharfRat wrote:Hello water and welcome to the Linux Mint forum :)

It has been a long time since I used nfs, but when using automount Synology Music w viewable credentials are you using sudo mount or plain mount :?:


Thanks! :D This looks like a very nice forum, and the great community is part of the reason I selected Mint as a distro!

I don't have to use NFS as a solution, it just seemed to be the way people set this type of thing up. I'm not trying to do anything too complicated, I'd like to simply stream FLAC files from a NAS music collection for playback on the local Mint machine. So if there is an easier/simpler way to do this, I'm all ears!


WharfRat wrote:The error alludes to not having the authority to mount it
mount: only root can mount 192.168.0.103:/volume1/Music on /home/water/MusicTarget


To not have to issue sudo you can add the user fstab option :wink:


If I include the user fstab option, as in the third example, I get the following error:
mount.nfs: an incorrect mount option was specified

I'm doing something incorrectly, and not sure what it is. :?

User avatar
WharfRat
Level 18
Level 18
Posts: 8440
Joined: Thu Apr 07, 2011 8:15 pm

Re: Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Postby WharfRat » Tue Mar 21, 2017 12:29 am

Oops, I missed that user option :oops:

I used NFS between two linux machines, not a NAS so Synology may not recognize that option even though it's a filesystem independent mount option.

I'll have to bow out here and have you wait for a member that has some experience what that device.
Image Image Image

water
Level 1
Level 1
Posts: 3
Joined: Mon Mar 20, 2017 10:06 pm

Re: Problem editing fstab, while attempting to mount NAS folder to Mint filesystem

Postby water » Tue Mar 21, 2017 3:39 pm

Thank you for your help. As my original goal that discovered this issue was to just stream music over a network, I discovered that an alternate solution could be used for now. Using the AudioStation package included with the Synology server, music can be played on a client computer via their AudioStation web interface.


Return to “Other networking topics”

Who is online

Users browsing this forum: No registered users and 1 guest