[SOLVED FOR REAL] Back to square one with Bluetooth

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

[SOLVED FOR REAL] Back to square one with Bluetooth

Postby JerryF » Tue Nov 21, 2017 9:42 pm

I haven't used bluetooth to transfer a file from my Android to my laptop for a while.

They seem to connect and I send a file from the Android to the laptop. I then get a notification on the Android that file has not been sent.

Help.
Last edited by JerryF on Fri Dec 01, 2017 7:47 pm, edited 2 times in total.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5307
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Back to square one with Bluetooth

Postby Spearmint2 » Tue Nov 21, 2017 10:05 pm

I can't help much on that other than directing you to the man file.

Code: Select all

man bluetoothd


Code: Select all

sudo apt-get install blueman


then look on panel for it's icon, an odd B shape.

Code: Select all

sudo apt-get install bluez-tools


http://segfault.linuxmint.com/2015/03/blueberry/

I'm using MATE and Control Center from the Menu button has bluetooth icon in it.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

JeremyB
Level 17
Level 17
Posts: 7558
Joined: Fri Feb 21, 2014 8:17 am

Re: Back to square one with Bluetooth

Postby JeremyB » Wed Nov 22, 2017 7:14 am

If you have LM18 Cinnamon open the Bluetooth Manager, and use the settings tab to enable incoming bluetooth file transfer. In LM17, see if Personal File Sharing is in the program menu

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Wed Nov 22, 2017 11:32 am

Spearmint2 wrote:I can't help much on that other than directing you to the man file.

Code: Select all

man bluetoothd


Code: Select all

sudo apt-get install blueman


then look on panel for it's icon, an odd B shape.

Code: Select all

sudo apt-get install bluez-tools


http://segfault.linuxmint.com/2015/03/blueberry/

I'm using MATE and Control Center from the Menu button has bluetooth icon in it.

Thanks for your reply. I have blueman and bluez-tools already installed. I don't have blueberry because I was instructed to remove it when I had this problem months ago.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Wed Nov 22, 2017 11:39 am

JeremyB wrote:If you have LM18 Cinnamon open the Bluetooth Manager, and use the settings tab to enable incoming bluetooth file transfer. In LM17, see if Personal File Sharing is in the program menu


Hi Jeremy,

Thanks so much for replying. I'm running 18.2 Cinnamon.

When I try to setup using Bluetooth Manager, I get this (side note---still can't directly attach pics to a post):
https://drive.google.com/open?id=1cV4cFVq4gNB7eIgXI3pII-Whe0C9aSxY

Last time, you had me install Personal File Sharing and I still have that. These are the settings:
https://drive.google.com/open?id=1x1vv016EtAksiEkTlOwclyQ_tM7tZwhd

P.S. Android says I'm connected and I can send a file from laptop to Android, but can't receive files from Android to laptop.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5307
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Back to square one with Bluetooth

Postby Spearmint2 » Wed Nov 22, 2017 1:20 pm

P.S. Android says I'm connected and I can send a file from laptop to Android, but can't receive files from Android to laptop.


That sounds more like it's a problem in the Android device. What happens if you check that box "share public files on network"? I'd also check your ufw settings.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Wed Nov 22, 2017 4:10 pm

Spearmint2 wrote:That sounds more like it's a problem in the Android device. What happens if you check that box "share public files on network"? I'd also check your ufw settings.

I checked the box for "share public files on network" and I turned off the firewall. Still no go.

I can send and receive a file using my phone and android.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5307
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Back to square one with Bluetooth

Postby Spearmint2 » Wed Nov 22, 2017 4:46 pm

Recently SMB1 was done away with due to exploit. I'm wondering if this is a conflict between one device still using it while the other is using SMB2? Although that's for windows.

They seem to connect and I send a file from the Android to the laptop. I then get a notification on the Android that file has not been sent.


This goes to the Public folder? Or to some other folder? What are the permissions on that folder?

This guy fixes his version 18.1 bluetooth. He went from blueberry back to blueman.

https://www.youtube.com/watch?v=j5mHo3X-_MI

http://alittlebitoflinux.blogspot.com/2 ... es-in.html
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Wed Nov 22, 2017 5:37 pm

From the laptop to Android, the file goes into a folder named "bluetooth".

From the Android to the laptop, the file is set up to go to the "Downloads" folder.

Permissions:

Code: Select all

drwxr-x---  5 jerry jerry   4096 Nov 22 16:10 Downloads
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

JeremyB
Level 17
Level 17
Posts: 7558
Joined: Fri Feb 21, 2014 8:17 am

Re: Back to square one with Bluetooth

Postby JeremyB » Wed Nov 22, 2017 5:51 pm

Jerry, had you already updated to LM18.2 when I had you uninstall Blueberry? Blueberry got reinstalled when I updated to 18.2, I think it did as I don't remember manually reinstalling it. I actually do not remember having the settings tab available in Blueberry. You could try changing the setting to not allow bluetooth in Personal File Sharing, close the window, reopen it and set it to allow bluetooth again

User avatar
Spearmint2
Level 14
Level 14
Posts: 5307
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Back to square one with Bluetooth

Postby Spearmint2 » Wed Nov 22, 2017 5:52 pm

https://www.cyberciti.biz/faq/how-linux ... ions-work/

Can you move that from android to laptop to put files into the Public folder instead? Otherwise you may need to change permissions for Downloads folder to allow "others" to at least "write" or both "read and write" to that folder. However, I'd think that the laptop giving permission to the bluetooth connection might override that.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Thu Nov 23, 2017 11:27 am

JeremyB wrote:Jerry, had you already updated to LM18.2 when I had you uninstall Blueberry? Blueberry got reinstalled when I updated to 18.2, I think it did as I don't remember manually reinstalling it. I actually do not remember having the settings tab available in Blueberry. You could try changing the setting to not allow bluetooth in Personal File Sharing, close the window, reopen it and set it to allow bluetooth again

Yes, I updated to 18.2. I haven't had it installed when I updated. Back in June, you had some kind of modification when I had kernel 4.4.0-79, but I do have security and kernel updates.

I will try the Personal File Sharing this afternoon when I get home.

Thanks so much.

P.S. When 18.3 is no longer beta, I'm going to do a fresh install of that instead of doing an in-place update.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Thu Nov 23, 2017 11:28 am

Spearmint2 wrote:https://www.cyberciti.biz/faq/how-linux-file-permissions-work/

Can you move that from android to laptop to put files into the Public folder instead? Otherwise you may need to change permissions for Downloads folder to allow "others" to at least "write" or both "read and write" to that folder. However, I'd think that the laptop giving permission to the bluetooth connection might override that.

I'll try that when I get home this afternoon.

Thanks.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Back to square one with Bluetooth

Postby JerryF » Thu Nov 23, 2017 8:05 pm

Hi JeremyB and Spearmint2,

Thank you for your responses. Now I can't even stay connected. The Android says it's paired with the laptop, but I notice that when I first pair up the devices, I get this:
https://drive.google.com/open?id=1LCQvG8nqhs3pbSBBredyeAU0UgPVM-uH

Then immediately, this:
https://drive.google.com/open?id=1vTR9jsvBO37xRwyq-MY6UI3tFNHxMA-P

The laptop seems to "unpair" as you can see on the right of the second pic.

I do thank you for your time and responses, but I'm not going to try this any further. I'll wait until 18.3 is out of beta and fresh install that. Then, even if this doesn't help the bluetooth problem, I'll leave it as is.

Thanks again.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
JerryF
Level 7
Level 7
Posts: 1725
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: [SOLVED FOR REAL] Back to square one with Bluetooth

Postby JerryF » Fri Dec 01, 2017 7:49 pm

I did a fresh install of 18.3 Cinnamon. I din't restore any of my Home config files.

I then set up Bluetooth. Then used Personal File Sharing and set that up.

I can now send and receive files to and from laptop and android!
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.


Return to “Other networking topics”