[SOLVED]DNS timing out but I can dig @ just fine

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
gm10
Level 13
Level 13
Posts: 4721
Joined: Thu Jun 21, 2018 5:11 pm

Re: DNS timing out but I can dig @ just fine

Post by gm10 » Tue Nov 13, 2018 1:25 am

ryron01 wrote:
Mon Nov 12, 2018 7:22 pm
uuugggggg I should have tried this awhile ago. So now I just need to figure why that file went missing and what I have to do to get NetworkManager to .... manage it.
Can't say I didn't ask you to check if that file was there. ;)

You do not need to create this manually, it gets created by resolvconf, so I'll just assume you disabled that service as well just like you had systemd-resolvd?

Code: Select all

sudo systemctl enable resolvconf
sudo systemctl restart resolvconf
sudo systemctl restart NetworkManager
You might want to have a look through your systemd configuation to check there isn't anything else disabled that shouldn't be:

Code: Select all

systemctl list-unit-files --state=disabled

ryron01
Level 1
Level 1
Posts: 11
Joined: Tue Nov 06, 2018 2:39 pm

Re: [SOLVED]DNS timing out but I can dig @ just fine

Post by ryron01 » Tue Nov 13, 2018 1:43 pm

I did a few more things to get this to work I needed to change the DNS settings in NetworkManager.conf to be default from dnsmasq and then I had to run

Code: Select all

sudo dpkg-reconfigure resolvconf
sudo systemctl restart resolvconf
sudo systemctl restart NetworkManager
gm10 wrote:
Tue Nov 13, 2018 1:25 am
ryron01 wrote:
Mon Nov 12, 2018 7:22 pm
uuugggggg I should have tried this awhile ago. So now I just need to figure why that file went missing and what I have to do to get NetworkManager to .... manage it.
You might want to have a look through your systemd configuation to check there isn't anything else disabled that shouldn't be:

Code: Select all

systemctl list-unit-files --state=disabled
I didn't see anything else that was disabled that shouldn't be, other than a timer I setup, which I fixed.

I think everything is in working order now. THANK YOU ALL for your help!!!!

Post Reply

Return to “Other networking topics”