[SOLVED] [somehow!] Samba - sorry to be a bother!

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
carrot007
Level 1
Level 1
Posts: 2
Joined: Fri Nov 08, 2019 5:55 pm

[SOLVED] [somehow!] Samba - sorry to be a bother!

Post by carrot007 » Fri Nov 08, 2019 6:13 pm

OK,

tldr, skip to [my issue] below....


[random background]
I upgraded my windows box.

So I had spare harware to upgrade my linux box (mainly file store, also maybe media server and sabnzb box if I feel the need).

After much pain on a 990 board with nonsence kusb dropping after boot (no keyb/mouse), that was fixed but no networking (wird on mb or wifi card).
So I found a 970 MB and used that, no loss for my linux box really. (unless you have other ideas, but another cpu swap is pain!)

My linux box has been debian since a long time. I have tried others but always gone back for various reasons. (How long who knows, I used 68k debian when it was supported, but only for fun, real debian use came a few versions later!


[my issue]
Having issues setting up samba for my shares.

Pretty much did in manually on a command line before. Though long time ago so I can't remember it! (I think my last install was debian 7 but upgraded to 9 over time in place).

I always liked mint for random laptops so I thought I would try it being debian related. (and less annoying find the random network firmware!)

So after installing 19.2

sudo apt install samba

used disks so mount 6 partitions I would like to share.

not occuring since I did not own points.

so.... sudo chown -R [user] [mountpoint] (sure it was chown -777 or something last time I did it, anyway...)

then in nemo it let me share it.

however whatever I use as the user/pass in windows (I was expecting my user.pass from mint) it will not connect. (I get access denied).

I am sure I did something dumb, so any help is appriciated. Even if it is a set up samba manually editing smb.conf (I can't even see the share in there so who knows these days!) etc.


All help appriciated.
Last edited by carrot007 on Sat Nov 09, 2019 10:39 am, edited 1 time in total.

altair4
Level 19
Level 19
Posts: 9738
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba - sorry to be a bother!

Post by altair4 » Fri Nov 08, 2019 6:29 pm

Without knowing how you set up your shares it's hard to know the source of the problem Posting the output of the following commands would help:

Code: Select all

testparm -s

Code: Select all

net usershare info --long
Based only on what you did post it sounds like you are passing a user/password combination that the Samba server is rejecting. The first thing that comes to mind is you didn't set up a samba password for that user. You do so with this command - changing altair to your own user name:

Code: Select all

sudo smbpasswd -a altair
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

carrot007
Level 1
Level 1
Posts: 2
Joined: Fri Nov 08, 2019 5:55 pm

Re: Samba - sorry to be a bother!

Post by carrot007 » Sat Nov 09, 2019 10:16 am

Additional 2: And a restart of the windows box made it work by name again! Probabced cached ip. Goes to show when setting things up and things act odd always restart everything ;-)

Additional. I did a restart just to make sure nopthing odd went on when I was trying things.

It now works, but only by IP, which is annoying! \\mintbox gets "you do not have permission", may have worked on IP all along? Any ideas about this development?

Thanks again.


Previous post:

Here is my output, should be pretty much as installed.

carrot007@mintbox:~$ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE

# Global parameters
[global]
dns proxy = No
log file = /var/log/samba/log.%m
map to guest = Bad User
max log size = 1000
obey pam restrictions = Yes
pam password change = Yes
panic action = /usr/share/samba/panic-action %d
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
passwd program = /usr/bin/passwd %u
server role = standalone server
server string = %h server (Samba, Ubuntu)
syslog = 0
unix password sync = Yes
usershare allow guests = Yes
idmap config * : backend = tdb


[printers]
browseable = No
comment = All Printers
create mask = 0700
path = /var/spool/samba
printable = Yes


[print$]
comment = Printer Drivers
path = /var/lib/samba/printers


And just one share set up for now. Was planning to add others when I got it working!

carrot007@mintbox:~$ net usershare info --long
[4tb1-Docs]
path=/mnt/4tb1-Docs
comment=
usershare_acl=Everyone:F,
guest_ok=n



A smbpasswd has been set up. Windows can see the share but as I say I just get access denied.


Thanks for any help.

Post Reply

Return to “Other networking topics”