Page 1 of 1

NFS Hangs on new 17 install

Posted: Thu Jun 26, 2014 9:21 am
by FFIXCollector
So I tried searching the Internet, and these forums, and could'nt find any information. So forgive me if this has been posted before.

I'm trying to mount a single NFS shares, but everything I do the command hangs for 20 - 60 seconds or it fails to execute

Code: Select all

sudo mount 192.168.0.777:/home/user/ /home/user/Server\ Home
I am running the same command, to the same server using Lubuntu, Fedora, Ubuntu, and a WD Live Streamer. None of them have issues, none of them take more than 3 seconds to connect. What could I be doing wrong?

Re: NFS Hangs on new 17 install

Posted: Thu Jun 26, 2014 1:54 pm
by txba516
FFIXCollector wrote:

Code: Select all

sudo mount 192.168.0.777:/home/user/ /home/user/Server\ Home
Your IP address is invalid. The last octet (.777) does not exist. The last number can be between .1 and .254. Perhaps you mean to use .77 instead?

Cheers!

Re: NFS Hangs on new 17 install

Posted: Thu Jun 26, 2014 5:02 pm
by FFIXCollector
yes 777 is fictitious

Re: NFS Hangs on new 17 install

Posted: Fri Jun 27, 2014 9:28 am
by txba516
Ok, I'm glad we agree on that point. But more importantly, did you type that in purposefully for the forum post or is that the actual IP address you are trying to mount the share from?

Re: NFS Hangs on new 17 install

Posted: Sat Jul 26, 2014 5:51 pm
by oscarjd74
I have the same, or at least a similar, problem. When trying to mount a nfs share from a client freshly installed with mint 17 the mount command hangs indefinitely. When I boot back into mint 15, which I have still lingering on another partition, the mount command works just fine. Both installs have the exact same line in /etc/fstab for the mount.

I must admit that I haven't gotten around to upgrading the server yet. It is still running mint 15. As such the client runs nfs-common version 1.2.8 while on the server both nfs-common and nfs-kernel-server are on version 1.2.6. Possibly this issue will resolve itself when I upgrade the server. I don't know. In either case I wasn't able to find any useful information about this problem anywhere on the internet either.

Re: NFS Hangs on new 17 install

Posted: Mon Sep 15, 2014 8:24 pm
by leo.smith
Hm. This MAY help Or not.

I didn't get indefinite hanging mounting older debian server NFS shares onto mint17 but I did get very long delays.

A bit of research revealed that NFS version incompatibilities exist and specifying the right version avoids timeouts and trying other protocols.

So the mount command needs to look something like this:

mount server1:/var/www /home/me/server1 -o nfsvers=3

Re: NFS Hangs on new 17 install

Posted: Mon Oct 20, 2014 2:08 pm
by FFIXCollector
leo.smith wrote:Hm. This MAY help Or not.

I didn't get indefinite hanging mounting older debian server NFS shares onto mint17 but I did get very long delays.

A bit of research revealed that NFS version incompatibilities exist and specifying the right version avoids timeouts and trying other protocols.

So the mount command needs to look something like this:

mount server1:/var/www /home/me/server1 -o nfsvers=3
I tried that option using NFS 3 & 4. Didn't help
The Server IP is 192.168.1.222