Page 1 of 1

Mint 16 Cinnamon Nemo Network Browsing (unsolved and closed)

Posted: Fri Feb 13, 2015 9:52 am
by Stryker1967
Hello all. I have a question I have not found addressed anywhere on the Internet, and need some help with it; In Nemo, under Network, I can only see my computer, and my windows workgroup. I click on windows workgroup, and I see WORKGROUP. Clicking on WORKGROUP, and it is blank. However, if I restart smbd and nmbs, I can see all my computers in Network in Nemo, and this lasts for about 10-15 seconds. Browsing Network, I can access any computer, and access it's shared files. But, after I hit the back button to get back to WORKGROUP to switch computers, if it has been longer than 10-15 seconds, only my computer shows up.....?

To give you an idea of the computers in my network;
FILESRVR = Lubuntu 13.10
TONY-NE56R = Linux Mint 16 Cinnamon (Also has Ubuntu Gnome 14 and Android 4.4 on it. I am only concerned with Mint right now)
EXTRA = Peppermint OS5 dual booting with Windows XP
SONSLAPTOP = Windows 7
SONSLAPTOP2 = Windows 8.1

FILESRVR can see and access all computers in PCMANFM Network browser, and the Windows computers can browse all computers.

SMBTREE on my laptop (TONY-NE56R) only shows my computer, and nmblookup can find all the computers. Currently I can access all computers by SMB://ipaddress and SMB://computername. I have all computers bookmarked in Nemo and Nautilus so that I can access them, but I would really like to be able to see them in Network Browsing. Interestingly; I trashed my copy of smb.conf one night out of frustration, and decided to "start over". After resharing my directories (Public, and Windows-Share), and editing smb.conf to add workgroup=WORKGROUP, restarting smbd and nmbd, I was able to brose all computers, and it held! Well, that is until I rebooted the computer an hour later..... Then we were back to only seeing my computer. Restarting smbd and nmbd again gave me 10-15 seconds of network browsing. Has anyone experienced this?

Re: Mint 16 Cinnamon Nemo Network Browsing

Posted: Sat Feb 14, 2015 3:00 pm
by Fornhamfred
As Mint 16 is no longer supported I would suggest that you upgrade to 17.1 which is an LTS version and may cure your problem.

Re: Mint 16 Cinnamon Nemo Network Browsing

Posted: Sun Feb 15, 2015 3:18 pm
by Stryker1967
Fornhamfred wrote:As Mint 16 is no longer supported I would suggest that you upgrade to 17.1 which is an LTS version and may cure your problem.
I just upgraded. I'll try it and report back.

Re: Mint 16 Cinnamon Nemo Network Browsing

Posted: Tue Feb 24, 2015 12:06 pm
by Stryker1967
Unfortunately that did not fix it. I did notice that my Peppermint OS5 computer browsed without any issues, so I switched to that OS, and have been browsing happily, without having to do any tweeks.