The location is not a folder

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
antcj
Level 2
Level 2
Posts: 92
Joined: Thu Jun 28, 2012 11:17 pm

The location is not a folder

Postby antcj » Thu Jul 16, 2015 6:33 pm

I have some files i keep on my media centre that is accessed by wife and i.
We are both on mint 17.2 mate.
On both pc's a particular file is set as a short cut in "places" ( a calc file.)
The following happens on a fresh boot, and happens only once and is then all good til the next reboot.

Could not display "smb://path to file name/file name.ods".
The location is not a folder.

a 2nd and subsequent try works fine.
I also have folders set as short cuts and they work fine
I have googled this and although there are various similar case nothing exactly the same

was wondering if anyone has any suggestions here?
Thanks in advance

UltramaticOrange
Level 3
Level 3
Posts: 104
Joined: Fri Sep 05, 2014 2:48 am

Re: The location is not a folder

Postby UltramaticOrange » Sat Jul 18, 2015 10:08 pm

I suspect that the media device is taking too long to respond to mint. To confirm this, try the following.

From the wife's machine, access the path/file (try #1, then try #2).
From your own machine, try to access the path/file again. If there's no error, then the media device is (partially) at fault.

The most likely cause is that the device has a low-power mode combined with a wake-on-lan feature.

antcj
Level 2
Level 2
Posts: 92
Joined: Thu Jun 28, 2012 11:17 pm

Re: The location is not a folder

Postby antcj » Sat Jul 18, 2015 10:15 pm

UltramaticOrange wrote:I suspect that the media device is taking too long to respond to mint. To confirm this, try the following.

From the wife's machine, access the path/file (try #1, then try #2).
From your own machine, try to access the path/file again. If there's no error, then the media device is (partially) at fault.

The most likely cause is that the device has a low-power mode combined with a wake-on-lan feature.


Tried that, even tho 1st pc can get thru the freshly booted machine has the problem on first go.

But thanks for the offering.

antcj
Level 2
Level 2
Posts: 92
Joined: Thu Jun 28, 2012 11:17 pm

Re: The location is not a folder

Postby antcj » Tue Jul 21, 2015 3:24 pm

slight update, noticed that on a reboot i can access a folder short cut on the media without any issues. (the folder has the file in question within it)
Closing the folder and then trying the file short cut then works .

User avatar
markmagedotcom
Level 1
Level 1
Posts: 1
Joined: Thu Nov 30, 2017 7:07 am

Re: The location is not a folder

Postby markmagedotcom » Thu Nov 30, 2017 12:08 pm

most likely, it's one of those old permissioin problems -- it usually is with like 99% of Unix/Linux troubles...

So you might want to try setting file (or device, media, drive etc...) ownership and permissions. It might be slightly different for your individual situation out there, but do try one or both of them, like so:

Code: Select all

sudo chown user:user /media/user/


and/or:

Code: Select all

sudo chmod 775 /media/user


For me, it solved that nasty problem right away!

Good Luck,

Mark
AKA markmagedotcom
Freelance Technology, Finance, and Travel Writer & Online Marketing Content Creator -- check this https://www.dreamstime.com/markmaege_info#res9237409 out if you're an image tech or drone video nerd, too...


Return to “Other networking topics”