Page 1 of 1

Can't write to SMB Share [SOLVED]

Posted: Mon Mar 27, 2017 6:27 pm
by WildPhydeaux
Linux Mint 18.1 Cinnamon 64-bit (but also experienced with LM 18.0)

Accessing SMB shares on a ReadyNAS Pro (also publishes the shares as NFS). No security on shares, files owned by nogroup/nobody.
I don't permanently mount the shares, I just have them bookmarked in Nemo.
When it asks me to logon, I can choose Anonymous or the Admin/password of the ReadyNAS admin - doesn't make any difference for the issue I'm having:

I can read/write/delete/execute etc (Octal permissions on all directories/files are 0777) with no problem from Nemo.

From applications, for example PuddleTag, I can open the files but not save changes:

An error occured while writing to /run/user/1000/gvfs/smb-share:server=pasqua,share=media/Music/801/(1976) 801 Live/01 Lagrima.flac

From Chrome browser, when downloading a file and choosing a save location on the NAS share - if the file is small, like picture.jpg it saves just fine. If the file is larger, say a couple megabytes, the save fails: Failed - download error.

About a year ago I installed Mint 18, replacing Mint 17 but as a fresh install (formatted, clean-slate). This has been the problem ever since. I did not have this problem in Mint 17 and don't recall doing anything special or having to work around any similar issue. I read that Mint 18 doesn't include Samba and thought maybe that was the issue, but installing Samba has not changed anything.

Sorry, this is likely a N00b thing, but I can't seem to surf down an answer...

Cheers,
RLW

Re: Can't write to SMB Share [SOLVED]

Posted: Tue Mar 28, 2017 7:16 pm
by WildPhydeaux
Like I said in my original post.... N00b thing...

Turns out apps don't care for accessing shares via gvfs. Had to mount the share and all is well.

Cheers,
RLW