Page 2 of 2

Re: My Firewall app seems to be broken

Posted: Tue Nov 21, 2017 7:10 pm
by MintBean
No - ignore that script. I replaced python with echo to report some information about your system based on a hunch I had that you might have multiple python versions installed. You don't, so it's null and void now.

What version of Mint are you running?

Re: My Firewall app seems to be broken

Posted: Tue Nov 21, 2017 7:20 pm
by Prsman
I am running mint 18 cinnamon. Tried to install 18.2 xfce but install crashed for some reason. If I can find some time I will try again.

Re: My Firewall app seems to be broken

Posted: Tue Nov 21, 2017 7:46 pm
by MintBean
Okay, I'm running 18.1,2,3 Cinnamon and no problems, so it's not that. If you have auto-login enabled, try disabling that and see if it makes a difference.

Re: My Firewall app seems to be broken

Posted: Mon Dec 11, 2017 8:33 pm
by Prsman
Just giving an update. I installed XFCE and still have this problem. It crashes with real time 0. In syslog I get a seg fault in the nvidia driver at this time.
Software Manger does this also, same failure. Not an operating system problem. Thanks for reading.

Re: My Firewall app seems to be broken

Posted: Mon Dec 11, 2017 10:00 pm
by WharfRat
gemk65,

Paste this in the terminal in one fell swoop, press enter if necessary and paste back the result.

Code: Select all

LOCATIONS=(
"/usr/share/gufw/gufw/gufw.py"
"/usr/lib/python2.7/site-packages/gufw/gufw.py"
"/usr/lib/python2.6/site-packages/gufw/gufw.py"
"/usr/lib/python2.7/dist-packages/gufw/gufw.py"
"/usr/lib/python2.6/dist-packages/gufw/gufw.py"
)
for ((i = 0; i < ${#LOCATIONS[@]}; i++)); do  if [[ -e "${LOCATIONS[${i}]}" ]]; then echo  ${LOCATIONS[${i}]} $1; fi; done

Re: My Firewall app seems to be broken

Posted: Tue Dec 12, 2017 7:37 pm
by Prsman
I had the very same problem as gemk65. I fixed my problem by running the nouveau driver for my video card. I hope you can find a solution so I can run the Nvidia driver for my card.

Code: Select all

prsman@AMD64 ~ $ inxi -Gx
Graphics:  Card: NVIDIA G72 [GeForce 7300 GS] bus-ID: 02:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           GLX Renderer: Gallium 0.4 on NV46
           GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes