Name Vhosts SSL to run NextCloud

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
dhenzler
Level 1
Level 1
Posts: 44
Joined: Sat Aug 20, 2016 1:27 pm

Name Vhosts SSL to run NextCloud

Postby dhenzler » Thu Aug 31, 2017 4:14 pm

Code: Select all

<VirtualHost *:443>
        SSLEngine on
        SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP

        SSLCertificateFile      /etc/ssl/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile   /etc/ssl/ssl-cert-snakeoil.key

        ServerName      "yourserver.com"
        DocumentRoot    "/var/www/html/nextcloud"

        CustomLog       "/var/log/httpd/one-access.log" combined
        ErrorLog        "/var/log/httpd/one-error.log"

        <Directory /var/www/html/nextcloud>
                AllowOverride All
                Order Allow,Deny
                Allow from all
                Require all granted
        </Directory>
</VirtualHost>


after putting this in /etc/apache2/sites-enabled I cannot restart apache2 or stop and start it with apachectl stop or start

NextCloud also uses a file in /var/www/html/nextcloud/config/config.php that has some domain stuff... does this have to be modified from regular port 80 use?

The following is a regular Vhost file that works...

Code: Select all

<VirtualHost *:80>
    DocumentRoot /var/www/html/duck/
    ServerName  duck.com
    ServerAlias www.duck.com
    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    <Directory /var/www/html/duck/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        #Order allow,deny
        #allow from all
        Require all granted
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error-duck.log
    CustomLog ${APACHE_LOG_DIR}/access-duck.log combined
</VirtualHost>

dhenzler
Level 1
Level 1
Posts: 44
Joined: Sat Aug 20, 2016 1:27 pm

SOLVED Name Vhosts SSL to run NextCloud

Postby dhenzler » Mon Sep 04, 2017 6:01 pm

SOLVED

The vhost file in my previous post WORKED, the reason I thought it didn't was a firewall error on my part. Once corrected it's fine.

The vhost file MUST be the FIRST ONE in your list. I suggest naming it 0-filename.conf

Dave


Return to “Other networking topics”