NFS file shares

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
User avatar
AndyMH
Level 3
Level 3
Posts: 170
Joined: Fri Mar 04, 2016 5:23 pm

NFS file shares

Postby AndyMH » Sun Oct 01, 2017 12:10 pm

I've got my laptop (lenova T430) backing up to a 256G SD card (in the express card slot) using a script running rsync. I've also got a synology NAS, so modified the script to give an option to either backup to SD card or diskstation.

I've set the mount point for the NAS at:

Code: Select all

/media/andy/diskstation
and within the script I've got

Code: Select all

sudo mount -t nfs 192.168.0.5:/volume1/homes/andy/backups /media/andy/diskstation
This all works, but with sudo does require me to enter my password. So I thought, lets put an entry in fstab so any user can mount the NFS share and I don't have to enter the password. The entry in fstab is

Code: Select all

192.168.0.5:/volume1/homes/andy/backups /media/andy/diskstation nfs rw,noauto,user,nofail 0 0
This works as well in that I can change the relevant lines in the script to

Code: Select all

mount /media/andy/diskstation
getting rid of sudo. BUT....

Instead of being prompted for my password, I now get a pop-up that says
authentication is required to start 'rpc-statd.service
and it still wants me to enter my password!!! No advance on what I had before.

Searching on the web has not yielded anything useful. I've not set the entry in fstab to automount because I'm not always connected to the NAS - delayed start up if it's not there? Any ideas, just trying to remove the need to enter the password when I run the script?
Andy

altair4
Level 18
Level 18
Posts: 8786
Joined: Tue Feb 03, 2009 10:27 am

Re: NFS file shares

Postby altair4 » Sun Oct 01, 2017 12:59 pm

I know nothing about NFS but the rpc-statd.service error looks like a bug. Here is the bug report with a possible workaround:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1624715
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
AndyMH
Level 3
Level 3
Posts: 170
Joined: Fri Mar 04, 2016 5:23 pm

Re: NFS file shares

Postby AndyMH » Sun Oct 01, 2017 1:13 pm

Thanks, I'd already tried:

Code: Select all

sudo  systemctl enable   rpcbind.service
sudo  systemctl start    rpcbind.service
systemctl restart  rpcbind.service

and it didn't help. Will try

Code: Select all

sudo systemctl reenable rpc-statd.service
sudo systemctl restart rpc-statd.service

and see what happens.
Andy


Return to “Other networking topics”