need assistance disabling Network Time Protocol (NTP)

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
ginahoy
Level 3
Level 3
Posts: 122
Joined: Sun May 28, 2017 3:15 pm

need assistance disabling Network Time Protocol (NTP)

Postby ginahoy » Mon Oct 30, 2017 4:20 pm

When I first installed Linux, I changed the "Time and Date" GUI configuration setting to 'Manual' so theoretically there shouldn't be any ntp traffic, right? HOWEVER, surprisingly, 3 months later, my system clock is still within 1 second of 'official' time, which in my experience, is highly unlikely without ntp. I suspect the manual setting is either broken or overridden by another process or admin privileges. My objective is to eliminate ntp traffic.

Rather than troubleshooting the Time & Date GUI, I prefer to simply disable the ntp process. As a new Linux user, I searched for instructions and found this page. I skipped the first part (add restriction to ntp.config file) and instead attempted to disable the ntp daemon (nptd) and close port 123. However, I get errors because paths don't match my LM 18.2 Xfce install, and I'm hesitant to make changes I don't understand.

I would be grateful if someone would explain the steps to disable the ntp daemon and close port 123, assuming these are indeed the appropriate actions to eliminate ntp traffic. Thanks!
Linux Mint 18.2 Xfce x64 | ASRock Z270 Extreme4 | Core i7 7700K | Cryorig H7 cooler| 32GB DDR4 2400| modded legacy Evercase LE4252 | EVGA 450W B3 | Samsung 850 EVO SSD

Return to “Other networking topics”