L2TP VPN Connection Help?

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
rfquerin
Level 1
Level 1
Posts: 8
Joined: Sun May 31, 2015 7:09 pm

L2TP VPN Connection Help?

Postby rfquerin » Tue Oct 31, 2017 12:28 pm

I am running Mint 18.1 and I've never had any luck connecting to my work VPN. I have no issues connecting with Win10, but can't get it to work in Linux. I've done a good amount of trying and I *think* it's an issue with the protocol. I set it up using information I got here on the forums and Network Manager doesn't instantly give me the unable to connect message. It does take about 10sec to see that. I have a copy of the log showing all the steps from connection to failure message, but I'm a little wary of whether it would be stupid (security wise) to post it here. It has IP addresses etc. I've posted below what I *think* is the key portion where it goes wrong (with some ip addresses redacted just in case). Hopefully someone might be able to shed some light on what's going wrong?

Code: Select all

Oct 29 13:08:16 eggsy charon: 14[IKE] received XAuth vendor ID
Oct 29 13:08:16 eggsy charon: 14[IKE] received DPD vendor ID
Oct 29 13:08:16 eggsy charon: 14[IKE] local host is behind NAT, sending keep alives
Oct 29 13:08:16 eggsy charon: 14[IKE] remote host is behind NAT
Oct 29 13:08:16 eggsy charon: 14[ENC] generating ID_PROT request 0 [ ID HASH ]
Oct 29 13:08:16 eggsy charon: 14[NET] sending packet: from 192.168.0.18[4500] to xx.xxx.xxx.xxx[4500] (68 bytes)
Oct 29 13:08:16 eggsy charon: 15[NET] received packet: from xx.xxx.xxx.xxx[4500] to 192.168.0.18[4500] (120 bytes)
Oct 29 13:08:16 eggsy charon: 15[ENC] parsed INFORMATIONAL_V1 request 1074287233 [ N(PLD_MAL) ]
Oct 29 13:08:16 eggsy charon: 15[ENC] ignoring unprotected INFORMATIONAL from xx.xxx.xxx.xxx
Oct 29 13:08:16 eggsy charon: 15[IKE] message verification failed
Oct 29 13:08:16 eggsy charon: 15[IKE] ignore malformed INFORMATIONAL request
Oct 29 13:08:16 eggsy charon: 15[IKE] INFORMATIONAL_V1 request with message ID 1074287233 processing failed
Oct 29 13:08:20 eggsy charon: 08[IKE] sending retransmit 1 of request message ID 0, seq 3
Oct 29 13:08:20 eggsy charon: 08[NET] sending packet: from 192.168.0.18[4500] to xx.xxx.xxx.xxx[4500] (68 bytes)
Oct 29 13:08:20 eggsy charon: 03[NET] received packet: from xx.xxx.xxx.xxx[4500] to 192.168.0.18[4500] (120 bytes)
Oct 29 13:08:20 eggsy charon: 03[ENC] parsed INFORMATIONAL_V1 request 362677490 [ N(PLD_MAL) ]
Oct 29 13:08:20 eggsy charon: 03[ENC] ignoring unprotected INFORMATIONAL from xx.xxx.xxx.xxx
Oct 29 13:08:20 eggsy charon: 03[IKE] message verification failed
Oct 29 13:08:20 eggsy charon: 03[IKE] ignore malformed INFORMATIONAL request
Oct 29 13:08:20 eggsy charon: 03[IKE] INFORMATIONAL_V1 request with message ID 362677490 processing failed
Oct 29 13:08:24 eggsy charon: 09[NET] received packet: from xx.xxx.xxx.xxx[500] to 192.168.0.18[500] (276 bytes)
Oct 29 13:08:24 eggsy charon: 09[IKE] received retransmit of response with ID 0, but next request already sent
Oct 29 13:08:25 eggsy NetworkManager[887]: nm-l2tp[8928] <warn>  Timeout trying to establish IPsec connection
Oct 29 13:08:25 eggsy NetworkManager[887]: nm-l2tp[8928] <info>  Terminating ipsec script with PID 9000.
Oct 29 13:08:25 eggsy NetworkManager[887]: Stopping strongSwan IPsec...
Oct 29 13:08:25 eggsy charon: 00[DMN] signal of type SIGINT received. Shutting down


greerd
Level 5
Level 5
Posts: 705
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: L2TP VPN Connection Help?

Postby greerd » Tue Oct 31, 2017 6:17 pm

Did you install strongswan? looks like it from your output. From synaptic, strongswan only supports IKEv1 and IKEv2 protocols.

Perhaps this link will help.
Image


Return to “Other networking topics”

Who is online

Users browsing this forum: No registered users and 1 guest