Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Newbie_from_NJ
Level 2
Level 2
Posts: 59
Joined: Mon Aug 11, 2014 6:31 pm

Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby Newbie_from_NJ » Mon Nov 06, 2017 10:20 pm

Hi guys,

Can someone please help me disable this? I did a search that recommended adding the following code to /etc/sysctl.conf

Code: Select all

# IPv6 disabled
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


I've done this, but my IPv6 address continues to be displayed on all these sites:
http://whatismyipaddress.com
http://ipv6-test.com/
http://test-ipv6.com/

sammiev
Level 4
Level 4
Posts: 230
Joined: Sat May 19, 2012 12:16 pm

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby sammiev » Mon Nov 06, 2017 10:29 pm

This worked for me while I was setting up my server.

http://ask.xmodulo.com/disable-ipv6-linux.html
Image

Newbie_from_NJ
Level 2
Level 2
Posts: 59
Joined: Mon Aug 11, 2014 6:31 pm

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby Newbie_from_NJ » Mon Nov 06, 2017 10:30 pm

On a side note, if I diable IPv6 on my laptop... does that mean I will only be able to access IPv4 servers?

Here's my dilemma. My VPN provider is IPVanish (which I don't believe supports IPv6 yet). So whenever I establish a VPN connection via Network Manager, it states "VPN connection has been successfully established". However, whenever I go and check my Public IP address on the sites from above, they all show my true IPv6 address along with my ISP. That's No Bueno, correct?

So what's a newbie to do in this case?

Newbie_from_NJ
Level 2
Level 2
Posts: 59
Joined: Mon Aug 11, 2014 6:31 pm

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby Newbie_from_NJ » Mon Nov 06, 2017 11:01 pm

OK I believe I've solved my dilemma:

-Open Network Connections
-Edit my SSID wifi connection
-Go to IPv6 Settings Tab
-method - Ignore
-Turn off wifi
-Turn on wifi

My connection is now only IPv4... and all the above websites now only read my IPv4 public IP address. Also, whenever I establish a VPN connections with IPVanish, only their server's IP address is being read.

Whenever I do not need to use my VPN, I can easily turn IPv6 back on.

This also solves another issue I previously reported on this forum, that never got resolved. My Network Manger Icon would never switch to the lock icon whenever I established a VPN connection. Now I understand why. Because it was never secured while I had IPv6 turned on. Now that I have disabled it, the Lock Icon is being displayed.

Newbie_from_NJ
Level 2
Level 2
Posts: 59
Joined: Mon Aug 11, 2014 6:31 pm

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby Newbie_from_NJ » Tue Nov 07, 2017 10:19 am

sammiev wrote:This worked for me while I was setting up my server.

http://ask.xmodulo.com/disable-ipv6-linux.html


Thank you for that link. Very informative. Now I know multiple ways.

sammiev
Level 4
Level 4
Posts: 230
Joined: Sat May 19, 2012 12:16 pm

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby sammiev » Tue Nov 07, 2017 12:54 pm

Your Welcome. :wink:
Image

User avatar
phd21
Level 13
Level 13
Posts: 4920
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Permanently Disable IPv6 On Mint 18.2 x64 Cinnamon?

Postby phd21 » Tue Nov 07, 2017 3:17 pm

Hi "Newbie_from_NJ",

Just FYI:

Disable IPv6 if its not supported
See #2 & #3 (I use #2 & #3)
http://www.blackmoreops.com/2015/08/04/how-to-disable-ipv6-in-linux/


When you edit your Local ISP connection in your Network Manager, you can also click the IPv4 tab and check IPv4 is required for this connection (in addition to clicking the Ipv6 tab and changing method to ignored).
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde


Return to “Other networking topics”