Cannot upload files to browser from SMB share

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Wed Dec 27, 2017 3:31 am

Cannot upload files to browser from SMB share

Post by xscout » Wed Dec 27, 2017 3:44 am

Hello everybody.
I'm using Mint 18.3 Cinnamon with all latest updates.

There is an annoying issue:
[*]Open smb share in file manager - "link" will be created on desktop and in nav tree
[*]Now start browser
[*]Navigate to "search by image" or any other file opload dialog
[*]There is no way to select file from share! No "link", no option to select network location.

Workaround - copy from share to desktop, upload in browser. It's very annoying in everday work.

How can i enable upload to browser from share?

Level 19
Level 19
Posts: 9453
Joined: Tue Feb 03, 2009 10:27 am

Re: Cannot upload files to browser from SMB share

Post by altair4 » Wed Dec 27, 2017 8:24 am

Open a terminal and run:

Code: Select all

nemo /run/user/$UID/gvfs/
When nemo opens up to that location immediately bookmark it: Bookmarks > Add Boorkmark

You will get a bookmark labelled gvfs ( you can rename it if you want ) that will show up on the side panel of nemo and the Open or Save dialogue in whatever application you use. Now after you connect to your samba share the mount point will show up under that gvfs Bookmark.

It will look a little weird ( smb-share:server=server-name,share=share-name ) but it is a legitimate file location.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”