VPN is not working in Sylvia

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
nanohead
Level 1
Level 1
Posts: 3
Joined: Thu Dec 28, 2017 10:34 pm

VPN is not working in Sylvia

Post by nanohead » Fri Dec 29, 2017 2:27 pm

OK, have tried everything. I'm a reasonably experienced Linux user who can usually solve most problems, but this one has me stumped completely.

Paid for a VPN service (pure vpn). It works perfectly fine on my windows 10 machines. But on my linux machines, it simply will not work...ever.

I've tried the following

Besides spending hours on chat with their (pretty responsive!) tech support, and trying all sorts of things, I've done all the below.
Clean install on Intel based system. Both 32 and 64 Bit.
Clean install on AMD based system. 64 Bit
PPTP connections to various servers
OpenVPN connections to various servers
Eliminating the router from the path and directly connecting my cable modem to the computer
Disabling IPV6
etc, etc.

Using PPTP, I get this message. "The VPN connection disconnected because the VPN service Stopped". I believe this is a Linux error message.

Using OpenVPN, it simply retries over and over then times out.

If it didn't work perfectly fine on several windows machines, I'd probably just give up, but now I need to find a solution! :shock:

User avatar
phd21
Level 16
Level 16
Posts: 6536
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: VPN is not working in Sylvia

Post by phd21 » Fri Dec 29, 2017 3:55 pm

Hi "nanohead",

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

First, everyone should use the "OpenVPN" protocol (UDP) because it is the most secure one.

Second, I have had some difficulty connecting to certain VPN provider's servers unless the OpenVPN client software is version 2.4 or higher. You can update this using the instructions in the link below.

Is it possible to install the latest openvpn on 17.3 without breaking everything[SOLVED]
viewtopic.php?f=157&t=242583&hilit=openvpn

FYI: Also, sometimes a VPN provider's server for a particular location gets overloaded, so try another one.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

nanohead
Level 1
Level 1
Posts: 3
Joined: Thu Dec 28, 2017 10:34 pm

Re: VPN is not working in Sylvia

Post by nanohead » Fri Jan 05, 2018 2:18 pm

Thanks so much for responding. Here's the screenshot..... Pretty plain jane stuff. installed 18.3 outta the box, no mods. just basic updates.

Did the OVPN updates, thanks for that. I tried doing an update through package manager, but I guess I needed to add the repo, so now it worked. Updated to 2.4.4

Will try to reconnect again
Attachments
mint screen.PNG

Post Reply

Return to “Other networking topics”