unable to sudo mount -a

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
cybermailer
Level 1
Level 1
Posts: 9
Joined: Tue Oct 31, 2017 6:01 am

unable to sudo mount -a

Post by cybermailer » Tue Jan 09, 2018 4:54 pm

Hi,

i have a very confusing problem, i want to mount my synology nas to my home folder Multimedia.

my fstab looks like:
this worked for while but now it doesn't
//synology/Multimedia /home/christopher/Multimedia cifs username=admin,passwd=xxx,domain=workgroup,user 0 0
i tried also:
//192.168.1.173/Multimedia /media/Multimedia cifs username=admin,password=xxx,iocharset=utf8,sec=ntlm,users 0 0

I can not try in terminal:
sudo mount -a

Error given:
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Now i have no idea what to check....pls hlp

User avatar
xenopeek
Level 24
Level 24
Posts: 21795
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: unable to sudo mount -a

Post by xenopeek » Tue Jan 09, 2018 5:11 pm

Looking at mount.cifs manpage as the error told you to do, for your first line there is no mention of a passwd option in the manpage only of password as you used on the second line. So I assume that's why the first line doesn't work.

For the second iocharset option does not have an argument according to the mount.cifs manpage and it is user not users according to fstab manpage. Likely why the second line doesn't work.

http://manpages.ubuntu.com/manpages/xen ... ifs.8.html
http://manpages.ubuntu.com/manpages/xen ... tab.5.html
Image

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Wed Jan 10, 2018 9:10 am

Have you done a firmware update on your nas device lately? Or have you changed it's configuration?
mount error(95): Operation not supported
You will get that error message if the SMB1 dialect has been disabled on the samba server running on the NAS.

Add another option to your original list:
//synology/Multimedia /home/christopher/Multimedia cifs username=admin,passwd=xxx,domain=workgroup,user,vers=2.0 0 0
If the samba server on the nas has SMB3 available you can also change the smb version to that:
//synology/Multimedia /home/christopher/Multimedia cifs username=admin,passwd=xxx,domain=workgroup,user,vers=3.0 0 0
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

cybermailer
Level 1
Level 1
Posts: 9
Joined: Tue Oct 31, 2017 6:01 am

Re: unable to sudo mount -a

Post by cybermailer » Thu Jan 11, 2018 4:10 am

i tried several ways, maybe some kind of error with my mint distro, i will try to connect with my raspberry to my nas and look what will happen...

I have to mention that it worked for quite a while, than i had problems with the keyring thing therefore i blocks from auto mounting my devices...

Do i have to disable keyring?

vimes666
Level 1
Level 1
Posts: 30
Joined: Tue Jan 19, 2016 6:08 pm

Re: unable to sudo mount -a

Post by vimes666 » Thu Jan 11, 2018 6:44 am

altair4 wrote: You will get that error message if the SMB1 dialect has been disabled on the samba server running on the NAS.
It is the kernel update on the client that breaks the SMB1 functionality. I have this same problem on my mint 18.3 mate computer since I updated the kernel to 4.13.0.26.
My nas (also a synology) was not changed and still supports SMB1 through SMB3.

Forcing the client to SMB with ver 2.0 or 3.0 in fstab resolves the problem partly.
The problem I was faced after that, was that the permissions of every file or folder I touched via the the client pc was changed to 666 or 777!
I have not found a solution for that.

Forther info: the kernel update for 17.3 does not cause this problem.. I am reluctant at this point to try it on my main pc (18.1)..

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Thu Jan 11, 2018 7:35 am

vimes666 wrote:It is the kernel update on the client that breaks the SMB1 functionality. I have this same problem on my mint 18.3 mate computer since I updated the kernel to 4.13.0.26.
My nas (also a synology) was not changed and still supports SMB1 through SMB3
It's true that the 4.13 kernel changed the default cifs smb dialect from smb1 to smb3 but if your synology device supports both smb1 through smb3 you should not have noticed any difference when connecting to the device.
The problem I was faced after that, was that the permissions of every file or folder I touched via the the client pc was changed to 666 or 777!
You have control of that on the client with dir_mode, file_mode, and if necessary nounix options in your cifs statement.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

vimes666
Level 1
Level 1
Posts: 30
Joined: Tue Jan 19, 2016 6:08 pm

Re: unable to sudo mount -a

Post by vimes666 » Thu Jan 11, 2018 7:45 am

altair4 wrote: You have control of that on the client with dir_mode, file_mode, and if necessary nounix options in your cifs statement.
dir_mode and file_mode only seem to have effect on what is displayed on the client side. On the server side 666 or 777 is set nevertheless :(
I was already pondering about the nounix option, I will try that later today.

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Thu Jan 11, 2018 7:48 am

@cybermailer

Open a terminal and run this command:

Code: Select all

smbclient -L //synology
Or

Code: Select all

smbclient -L //192.168.1.173
Do you get this error message: protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

vimes666
Level 1
Level 1
Posts: 30
Joined: Tue Jan 19, 2016 6:08 pm

Re: unable to sudo mount -a

Post by vimes666 » Thu Jan 11, 2018 10:36 am

altair4 wrote: You have control of that on the client with dir_mode, file_mode, and if necessary nounix options in your cifs statement.
I tried nounix, same problem. I think that I have to solve this on the synology side. However your suggestion to force the client into SMB 1.0 (viewtopic.php?f=157&t=261424#p1412849) did the trick! All is back to normal. Now I have at least some time to figure what going wrong with my permissions. Thanks a lot!

I am not sure wheather this helped the topic starter too.

cybermailer
Level 1
Level 1
Posts: 9
Joined: Tue Oct 31, 2017 6:01 am

Re: unable to sudo mount -a

Post by cybermailer » Thu Jan 11, 2018 3:59 pm

in terminal i tried what you mentiond this is the output:
session setup failed: NT_STATUS_LOGON_FAILURE
Today i tried to connect my raspi with my nas -> without any problem -> therefore it must be a kernel/mint thing...

I connected my syn nas successfully with:
//synology/Multimedia /home/pi/Multimedia cifs username=xxx,password=xxx,domain=xxx,user 0 0

Youre right adding vers=1.0 seems to work for now.
//synology/Multimedia /home/pi/Multimedia cifs username=xxx,password=xxx,domain=xxx,vers=1.0,user 0 0

How should i go with this situation right now? Waiting for updates? Troubleshooting? Leaving all how it is now? thx for helping!!

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Thu Jan 11, 2018 4:31 pm

cybermailer wrote:Youre right adding vers=1.0 seems to work for now.
//synology/Multimedia /home/pi/Multimedia cifs username=xxx,password=xxx,domain=xxx,vers=1.0,user 0 0

How should i go with this situation right now? Waiting for updates? Troubleshooting? Leaving all how it is now? thx for helping!!
That's the way the previous kernel default mounted the share so all you did was revert to how it used to be. It's about the only thing you can do if your server only speaks SMB1.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

cybermailer
Level 1
Level 1
Posts: 9
Joined: Tue Oct 31, 2017 6:01 am

Re: unable to sudo mount -a

Post by cybermailer » Thu Jan 11, 2018 4:37 pm

ah ok. that means synology side problem?

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Thu Jan 11, 2018 5:06 pm

I don't know anything about the synology device so I cannot answer that question.

This topic is somewhat discombobulated so let me attempt to clarify because the original error could be the result of two different things.

Prior to Linux Kernel 4.13 the default version of SMB that cifs used was vers=1.0. If the server does not speak SMB1 because the server disabled it the Linux client user has to pass a vers=2.0 or vers=3.0 to gain access.

After Linux Kernel 4.13 the default version of SMB that cifs uses is vers = 3.0. If the server only speaks SMB1 or SMB2 the Linux client user has to pass vers=1.0 or vers=2.0.

One way to determine which version the server will accept is to run the smbclient -L //server command. smbclient at the moment only uses smb1 regardless of kernel so if you got this this error message protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE the server does not speak vers=1.0.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

pcwolf
Level 1
Level 1
Posts: 20
Joined: Fri Dec 22, 2017 12:08 am

Re: unable to sudo mount -a

Post by pcwolf » Mon Jan 15, 2018 6:19 pm

smbclient -L //Synology

smbclient -L //server

Both result in: "Connection to server failed (Error NT_STATUS_IO_TIMEOUT)"

Mint KDE 18.3 with kernel 4.13.0.26 here for me. Synology shares worked before kernel upgrade. Just another data point.

-Phil

altair4
Level 18
Level 18
Posts: 8875
Joined: Tue Feb 03, 2009 10:27 am

Re: unable to sudo mount -a

Post by altair4 » Mon Jan 15, 2018 7:01 pm

Assuming there really is a host with the name Synology you did not get the protocol negotiation failed error so your device speaks smb1. You should be able to connect to it from the file manager.

If not you have a problem different from this topic/.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”