[SOLVED] No internet in VPN: Nameserver configuration in vpnc

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 9
Joined: Mon Jan 08, 2018 1:11 pm

[SOLVED] No internet in VPN: Nameserver configuration in vpnc

Post by yobro » Thu Feb 08, 2018 11:54 am


I use vpnc (cisco-compatible) to connect to a vpn via wifi on linux mint 18.3.

Apparently, the network-manager does not fetch the correct settings from the VPN for the name resolving – I can access the Intranet, but the internet is not available via the VPN

I installed sudo apt install vpnc network-manager-vpnc network-manager-vpnc-gnome.

If I change the Method under IPv4 Settings to Automatic (VPN) Addresses only and add the DNS servers of our VPN, the internet is accessible, but the parts of the Intranet, such as the samba file server are not available.

A co-worker of mine has the same set-up under Ubuntu 17.10 and does not have the problem.
How could I teach Linux Mint to fetch the correct settings from the VPN?

Thanks for your help,

The output of inxi -Fxz is

Code: Select all

System:    Host: lifebook-e756 Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: FUJITSU product: LIFEBOOK E756 v: 10601115935
           Mobo: FUJITSU model: FJNB292 v: N4 Bios: FUJITSU // Insyde v: Version 1.21 date: 11/15/2017
CPU:       Dual core Intel Core i7-6600U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11232
           clock speeds: max: 3400 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz, 2560x1440@59.95hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel Ethernet Connection I219-LM driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (18.9% used) ID-1: /dev/sda model: Micron_1100_MTFD size: 256.1GB
Partition: ID-1: / size: 218G used: 30G (15%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 133M (30%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 17.06GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 224 Uptime: 5:45 Memory: 2972.1/15928.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by yobro on Fri Feb 23, 2018 6:05 am, edited 1 time in total.

Level 1
Level 1
Posts: 9
Joined: Mon Jan 08, 2018 1:11 pm

Re: No internet in VPN: Nameserver configuration in vpnc

Post by yobro » Fri Feb 23, 2018 6:05 am

The solution was removing the line dns=dnsmasq in the file /etc/NetworkManager/NetworkManager.conf and reboot.

Code: Select all



Post Reply

Return to “Other networking topics”