PIA VPN Dropping Out Ater Upgrade - Solved

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
handyman4848
Level 1
Level 1
Posts: 38
Joined: Fri Nov 30, 2012 3:41 pm

PIA VPN Dropping Out Ater Upgrade - Solved

Post by handyman4848 » Fri Feb 16, 2018 9:39 pm

I am experiencing a weird problem with my PIA VPN dropping out after varying periods of time. I have been using PIA for quite a long time, since Linux Mint 13 on the Mate Desktop and had no problem until I upgraded from Linux Mint 17 Mate to Mint 17.3 Mate. After considerable time and frustration and with assistance from my ISP, PIA Tech Support and various internet searches, changing port settings and udp to tcp all to no avail, I switched to the Cinamon Desktop (for totally unrelated reasons) and suddenly the problem was solved.

All was well for over a year then I upgraded to Linux Mint 18.3 Cinamon and now the problem is back. I tried the afore mentioned suggestions but once again they have no effect on my problem. My VPN service keeps dropping connections after varying amounts of time. The problem seems to be worse at busy internet times like around noon or 5 to 6 pm but that might be my imagination.In any case I upgraded my internet service from 6Mbps to 30 Mbps and that did not help. (Speeded up my downloads though.):-)

Since the problem only occurred after upgrading from Mint 17 to Mint 17.3 on the Mate desktop, was cured by changing to the Cinamon desktop on Mint 17.3 and came back after upgrading to Mint 18.3 Cinamon, I can only conclude that the problem lies somewhere in Linux Mint 18.3 and not with PIA, my ISP or my setup.

Does anyone have an idea what the problem might be?
Last edited by handyman4848 on Tue Feb 20, 2018 1:27 pm, edited 2 times in total.

Charlie
Level 4
Level 4
Posts: 240
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: PIA VPN Dropping Out Ater Upgrade

Post by Charlie » Sat Feb 17, 2018 7:01 am

I had similar problems with my VPN and my DNS settings were the culprit. They would randomly vanish, disappear from view. The powersave function of my WiFi was also enabled and I had not set my country in the WiFi settings. I have rectified all of those problems and now have a rock solid connection. I don't remember the code to solving them but a board search should reveal all. Or someone more knowledgeable may help.

handyman4848
Level 1
Level 1
Posts: 38
Joined: Fri Nov 30, 2012 3:41 pm

Re: PIA VPN Dropping Out Ater Upgrade - Solved

Post by handyman4848 » Tue Feb 20, 2018 1:30 pm

Problem solved! I installed and set up my PIA VPN following step by step instructions downloaded from the PIA forum, as recommended by PIA tech support when I had my previous troubles a year ago.When comparing my new set-up with my old settings I noticed that "Method" under the IPv4 tab was set to "Automatic (VPN)" instead of "Automatic (VPN) addresses only" as in my old set-up. This step was omitted in the set-up instructions I used and when I changed it to "Automatic (VPN) addresses only" the problem was resolved.

Post Reply

Return to “Other networking topics”