Page 1 of 1

[SOLVED]Mint won't connect to Bose Mini Soundlink

Posted: Sun Mar 04, 2018 5:02 am
by Gerstacker
Hi guys!

yesterday I tried connecting via Bluetooth to my Bose Mini Soundlink to listen to music on Clementine, and even though the connection was successful (I heard the Soundlink "click," the sound it does when it connects) Clementine continued playing music on the laptop's sound, and when I tried for instance watching a trailer on Youtube the result was the same (the sound wasn't played on the Soundlink but on the laptop).

What gives?

Here are my hardware specs:
System: Host: akhenaten-XPS-13-9360 Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine: System: Dell (portable) product: XPS 13 9360
Mobo: Dell model: 0TPN17 v: A00 Bios: Dell v: 2.5.1 date: 01/25/2018
CPU: Quad core Intel Core i7-8550U (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15936
clock speeds: max: 4000 MHz 1: 2000 MHz 2: 2000 MHz 3: 2000 MHz 4: 2000 MHz 5: 2000 MHz
6: 2000 MHz 7: 2000 MHz 8: 2000 MHz
Graphics: Card: Intel Device 5917 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 3200x1800@59.98hz
GLX Renderer: Mesa DRI Intel Kabylake GT1.5
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network: Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
driver: ath10k_pci bus-ID: 3a:00.0
IF: wlp58s0 state: up mac: <filter>
Card-2: Atheros usb-ID: 001-004
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives: HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
Optical: No optical drives detected. (Oddly doesn't detect my M.2 PCIe NVMe 256GB SSD?)
Partition: ID-1: / size: 46G used: 6.3G (15%) fs: ext4 dev: /dev/nvme0n1p1
ID-2: /home size: 175G used: 131G (79%) fs: ext4 dev: /dev/nvme0n1p2
ID-3: swap-1 size: 16.06GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 61.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 270 Uptime: 7:00 Memory: 2863.1/7573.8MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0c45:670c Microdia
Bus 001 Device 005: ID 04f3:2234 Elan Microelectronics Corp.
Bus 001 Device 004: ID 0cf3:e300 Atheros Communications, Inc.
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 008: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Re: Mint won't connect to Bose Mini Soundlink

Posted: Sun Mar 04, 2018 11:41 am
by CaptainKirksChair
Click on Menu > Preferences > Sound

Your bluetooth device should show up as a device at the top. Select it and configure the parameters below.

Re: Mint won't connect to Bose Mini Soundlink

Posted: Mon Mar 05, 2018 9:16 am
by Gerstacker
Hi CaptainKirksChair!

thanks for replying :)

When I go to Preferences -> Sound, even after connecting the device to the laptop's Bluetooth, it does not appear under "Device" :(

Re: Mint won't connect to Bose Mini Soundlink

Posted: Mon Mar 05, 2018 9:54 am
by Ozo
It would appear in Bluetooth automatically but you click on it (the name) to setup. You must select it also in Sound. click on the name Bose Mini Sound Link in bluetooth and you will see something like what is in my third photo.

You said it is not listed in Sound. does it appear in Bluetooth? If so does it say "not set up yet". If so you must get the bluetooth light on the mini to flash and it should link automatically. As I recall, this all works easier than it did with Windows, just saying.

As you see the Mini should work in 18.3 Sylvia just fine (I can hear it).




As an afterthought, you can connect directly from the earphone connector to the auxiliary connector on the mini.

Re: Mint won't connect to Bose Mini Soundlink

Posted: Mon Mar 05, 2018 2:39 pm
by Ozo
I once had the Bose Mini set up and looked like it was perfectly ok. I could see progress on the media player but there was no music. Hmm, all the lights were correct. I looked at Sound and it was high lighted as it should be so I gave her a little nudge. I clicked the other option (built in audio which worked) and then clicked the Bose option. Sound pouring from the speakers is such a joy. :D

The problem with the Mini at least the generation that I have is that to save the battery it shuts off automatically after 5 minutes when the computer shuts down. After a restart the Bose Mini will disconnect too and you will have to restart the bluetooth app, turn it off then back on.

There is a simple solution. When you start the computer after being shut down for more than five minutes it will not always connect but if you start the Mini FIRST it will then connect automatically when the computer starts. There is no need to push the Bluetooth button on the Mini, just push start. :)

This was all true for Windows too not just Mint. :mrgreen:

EDIT: Sometimes if it will not connect (not seen in Sound) you have to reset the Bose Mini (turn it off and back on). No need to push the Bluetooth icon in this case.

The Bose Soundlink Mini II does not shut off automatically so is a much better system to use as a home stereo.

Posted: Wed Mar 07, 2018 11:52 am
by Gerstacker
Hi Ozo,

thank you so much for your replies!

I have since been able to see Bose Mini Soundlink appear under "Sound" but whenever I open Chrome even though the Bluetooth is still connected to the BMS, under "Sound" it disappears and I can't hear sound anymore on VLC and Rhythmbox, but I can on Chrome.

This is the only "buggy" item left in an otherwise stellar and I should say very visually appealing, if also subdued, Linux Mint Cinnamon 18.3 Sylvia, which has fit like a glove on my supercharged Dell XPS 13 9360 13.3" i7 U8550 8GB RAM 256GB SSD QHD+ 3200x1800 beast.

(Had to change from Transmission back over to qBittorrent after Transmission required opening of ports which even after opening it didn't recognize as open, even though qBittorrent, like Double Commander and Clementine, among other Linux apps, is not yet tailored for QHD+ HiDPI screens so everything appears tiny)

Re: Mint won't connect to Bose Mini Soundlink

Posted: Wed Mar 07, 2018 1:34 pm
by Ozo
When the player is operating correctly with the mini as output you will see this after a right click of the music note icon on the panel, then select Output device.


With a left click of the Music note icon you should see whats playing if anything. If the player is not playing then you will not see the music note icon.


Re: Mint won't connect to Bose Mini Soundlink

Posted: Wed Mar 07, 2018 2:17 pm
by Gerstacker
Hi Ozo,

thanks again!

I have Firejail Sandbox installed and am using it on Chrome.

Did some searching and found some commands which I put on Terminal and now the problem has disappeared. Everything working ship-sharp :)

This OS keeps teaching me to be patient...with some reading one can solve pretty much any problem that arises.

And, if it's running well, it really is superior to Windows. Looks slick, and I only had to make a 12GB partition for it, which still has 4.7GB free!!!

Still getting used to LibreOffice Writer instead of Microsoft Word...but once that transition is complete I don't think I'll ever want anything else.

Re: Mint won't connect to Bose Mini Soundlink

Posted: Wed Mar 07, 2018 4:00 pm
by Ozo
Glad to hear that.

There are many things you can do to make Mint look better and perform better. I put a dock on the side hidden. I added Cerebro which is a truly awesome search utility. I have installed themes etc.

I too use Chrome and have added extensions like Nimbus and ad block+ to it as well as a theme.