NFS Shares on NAS not mounting.....

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
cranksv477
Level 1
Level 1
Posts: 3
Joined: Fri Apr 20, 2018 7:20 pm

NFS Shares on NAS not mounting.....

Post by cranksv477 » Fri Apr 20, 2018 7:38 pm

Hi All,

This is my first post here and I ask that you have some patience with me as the terms I use may not be 'technical'. I am still learning about Mint 18.3. I run a dual boot pc with Mint & Win10.

What I want is for my NAS shared folders to be mounted and bookmarked so that I can access them when using GMail attach file action....as seen in below screen shot...
Add attachment GMail.png
I was able to browse the NAS folders but now they folders are empty - I can view all folders this way on my Win10 partition.

To mount the folders I added these lines to my /etc/rc.local, then bookmarked them in file manager.

mount -t nfs 192.168.1.88:/@realty /mnt/qnap/@realty
mount -t nfs 192.168.1.88:/Craig /mnt/qnap/Craig

As I said this is not working now...

Any help appreciated.

User avatar
catweazel
Level 17
Level 17
Posts: 7113
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS Shares on NAS not mounting.....

Post by catweazel » Fri Apr 20, 2018 9:23 pm

cranksv477 wrote:
Fri Apr 20, 2018 7:38 pm
mount -t nfs 192.168.1.88:/Craig /mnt/qnap/Craig
In a terminal, try:

sudo mount -o vers=3 192.168.1.88:/Craig /mnt/qnap/Craig
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

cranksv477
Level 1
Level 1
Posts: 3
Joined: Fri Apr 20, 2018 7:20 pm

Re: NFS Shares on NAS not mounting.....

Post by cranksv477 » Mon Apr 23, 2018 6:53 am

Ahhhh that works thanx.. and I can create a Bookmark too!! :D :D

What do I need to do to make this work every time my pc boots up?

cranksv477
Level 1
Level 1
Posts: 3
Joined: Fri Apr 20, 2018 7:20 pm

Re: NFS Shares on NAS not mounting.....AGAIN!!!! argghhhh

Post by cranksv477 » Wed May 23, 2018 2:56 am

Ah crap!!

My NFS Shares are not mounting again...this time since the last update today!!

FYI... to overcome this problem last time I blew away the distro and reinstalled it and my shares mounted, no probs at all.

But since today's update, they no longer mount!

What on earth is the problem???..... this is very frustrating! :cry: :cry: :cry:

Someone....anyone please help!!

Ralph124c41
Level 1
Level 1
Posts: 1
Joined: Tue Sep 20, 2016 7:07 pm

Re: NFS Shares on NAS not mounting.....

Post by Ralph124c41 » Wed May 30, 2018 11:11 pm

I'm now in the same boat. A reboot has lead to not being able to mount my network drive shares.
The drive is still up, as I can access it from other machines, and even from my Mint box via the web server on the drive. I just can't mount them.
Something in cifs is broken.

syslog:
May 30 10:41:25 MACHINENAME kernel: [ 3037.635896] CIFS VFS: Error connecting to socket. Aborting operation.
May 30 10:41:25 MACHINENAME kernel: [ 3037.636198] CIFS VFS: cifs_mount failed w/return code = -111

Post Reply

Return to “Other networking topics”