NFS mount in /etc/fstab of my QNap shares

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Thomsterdam
Level 1
Level 1
Posts: 24
Joined: Wed Apr 06, 2016 9:53 am

NFS mount in /etc/fstab of my QNap shares

Post by Thomsterdam » Thu Jun 21, 2018 5:32 pm

Is there anyone who has successfully mounted a number of QNap shares via /etc/fstab? I have done this:
* turn on NFS access in QNap,
* configure NFS access for all shares from all computers in the network
* add lines in the computer's firewall config for connecting between the computer and the NAS
* add this line to my /etc/fstab :
* [ipadresofmyQNapNAS]/Backup /home/[myusername]/NAS/Backup nfs _netdev,auto 0 0

Then I enter: sudo mount -a
I get this error message:

Code: Select all

mount.nfs: access denied by server while mounting [ipadresofmyQNapNAS]:/Backup
So why does the QNap still deny access?
I hope there are Linux Mint users who have tackled this. It is driving me insane.
(BTW: I'm not interested in SMB/CIFS, I need NFS).

Thanx in advance,

Peter

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Fri Jun 22, 2018 1:44 am

Thomsterdam wrote:
Thu Jun 21, 2018 5:32 pm

Code: Select all

mount.nfs: access denied by server while mounting [ipadresofmyQNapNAS]:/Backup
All we know is that you get that message, and we won't know anything more until you post your fstab, or at least the line in fstab that's causing the error.
There are no silly questions, but there are silly answers.

altair4
Level 19
Level 19
Posts: 9152
Joined: Tue Feb 03, 2009 10:27 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by altair4 » Fri Jun 22, 2018 6:25 am

* add this line to my /etc/fstab :
* [ipadresofmyQNapNAS]/Backup /home/[myusername]/NAS/Backup nfs _netdev,auto 0 0
I haven't used NFS since the Boer Wars but I don't think that is the right syntax for an NFS mount in fstab. In fact it looks like a cifs mount syntax except for the "nfs" entry.

Shouldn't the syntax be more like:
[ipadresofmyQNapNAS]:/Backup /home/[myusername]/NAS/Backup nfs <options> 0 0
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Fri Jun 22, 2018 6:28 am

altair4 wrote:
Fri Jun 22, 2018 6:25 am
Shouldn't the syntax be more like:
[ipadresofmyQNapNAS]:/Backup /home/[myusername]/NAS/Backup nfs <options> 0 0
lol - my old eyes don't see code unless it's [ⅽoded]
There are no silly questions, but there are silly answers.

User avatar
Thomsterdam
Level 1
Level 1
Posts: 24
Joined: Wed Apr 06, 2016 9:53 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by Thomsterdam » Fri Jun 22, 2018 7:10 am

Hi Catweazel, altair,
Thanx for your replies.
As you can see in the initial message, I had put this line in my fstab:

Code: Select all

[ipadresofmyQNapNAS]/Backup /home/[myusername]/NAS/Backup nfs _netdev,auto 0 0 
I hadn't put it between

Code: Select all

code
but it was all there.
Perhaps you could elaborate on the options that I should include and how I should change it to get it to work?
The problem is: it worked before with my NetGear NAS and it worked with my QNap NAS until I did a factory reset. So do you know how this works specifically with a Qnap NAS?
Thanx,

Thom

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Fri Jun 22, 2018 6:44 pm

Thomsterdam wrote:
Fri Jun 22, 2018 7:10 am
Hi Catweazel, altair,
it worked with my QNap NAS until I did a factory reset.
The first thing to check is that you're exporting NFS shares to the correct IP addresses.
There are no silly questions, but there are silly answers.

User avatar
Thomsterdam
Level 1
Level 1
Posts: 24
Joined: Wed Apr 06, 2016 9:53 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by Thomsterdam » Sat Jun 23, 2018 6:01 am

Yes it is :shock:

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Sat Jun 23, 2018 6:37 am

Thomsterdam wrote:
Sat Jun 23, 2018 6:01 am
Yes it is :shock:
Try mounting a share manually.

Code: Select all

mount -o vers=3 IP.Add.ress:/Network/Share/Name /mount.point

Code: Select all

[ipadresofmyQNapNAS]/Backup /home/[myusername]/NAS/Backup nfs _netdev,auto 0 0
There should be a colon after [ipadresofmyQNapNAS]. Try this:

Code: Select all

[ipadresofmyQNapNAS]:/Backup /home/[myusername]/NAS/Backup nfs defaults 0 0
Of course, /home/[myusername]/NAS/Backup must also exist.
There are no silly questions, but there are silly answers.

User avatar
Thomsterdam
Level 1
Level 1
Posts: 24
Joined: Wed Apr 06, 2016 9:53 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by Thomsterdam » Sat Jun 23, 2018 7:04 am

Unfortunately I get the same result:

Code: Select all

mount.nfs: access denied by server while mounting 192.168.178.44:/Backup

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Sat Jun 23, 2018 7:07 am

Thomsterdam wrote:
Sat Jun 23, 2018 7:04 am
Unfortunately I get the same result:

Code: Select all

mount.nfs: access denied by server while mounting 192.168.178.44:/Backup
Well, apart from double-checking your machine's IP address against the shares and IP addresses that are exported on your server, I can't offer anything else, except perhaps asking you to post /etc/exports from the server.
There are no silly questions, but there are silly answers.

User avatar
Thomsterdam
Level 1
Level 1
Posts: 24
Joined: Wed Apr 06, 2016 9:53 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by Thomsterdam » Sat Jun 23, 2018 7:26 am

Hey Catweazel,
Thanx for your efforts. I was hoping there might be someone on this forum who is familiar with both QNap NASs and Linux Mint.
Anyone?

Thanx.

User avatar
catweazel
Level 16
Level 16
Posts: 6277
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: NFS mount in /etc/fstab of my QNap shares

Post by catweazel » Sat Jun 23, 2018 7:42 am

Thomsterdam wrote:
Sat Jun 23, 2018 7:26 am
I was hoping there might be someone on this forum who is familiar with both QNap NASs and Linux Mint.
It's linux. Familiarity with QNAP NAS isn't required.
There are no silly questions, but there are silly answers.

altair4
Level 19
Level 19
Posts: 9152
Joined: Tue Feb 03, 2009 10:27 am

Re: NFS mount in /etc/fstab of my QNap shares

Post by altair4 » Sat Jun 23, 2018 7:47 am

Have you seen these:

This one about how to set up the QNAP: Mount Qnap NFS Share on Linux OS

And this one from QNAP: Mounting an NFS share on Ubuntu
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”