Page 1 of 1

[SOLVED] MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 12:06 am
by all41
It seems nothing has changed in Mint 19 regarding bluetooth connectivity.
I use a T651 Wireless Trackpad which gets recognized, paired, and connected.
But after reboot I have to go back into the gui, select the recognized device, and enter reconnect to get it to work.

This is a continuing issue I had in 17.3 where I was able to mitigate by:

Code: Select all

bt-input -c <mac_address>
This does not work with Mint 19.
Not a major issue, but a nag--after boot I have to, click on the bluetooth panel icon, click on the recognized device and select 'On' and do this every boot.
Also tried removing blueberry and installing blueman--same results.
Does someone have an idea how to automate this bluetooth connection using Mint 19?

Code: Select all

uno@labonline:~$ inxi -Fxz
System:    Host: labonline Kernel: 4.15.0-23-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: LENOVO product: 4157D51 v: ThinkStation S20 serial: N/A
           Mobo: LENOVO model: LENOVO serial: N/A
           BIOS: LENOVO v: 60KT47AUS date: 01/15/2014
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Rechargeable Trackpad T651 status: Full
CPU:       Quad core Intel Xeon W3550 (-MT-MCP-) 
           arch: Nehalem rev.5 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 24470
           clock speeds: max: 3060 MHz 1: 1595 MHz 2: 1595 MHz 3: 1595 MHz
           4: 1598 MHz 5: 1595 MHz 6: 1595 MHz 7: 1595 MHz 8: 1597 MHz
Graphics:  Card: NVIDIA G96GL [Quadro FX 580] bus-ID: 02:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@59.93hz
           OpenGL: renderer: Quadro FX 580/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.106 Direct Render: Yes
Audio:     Card Intel 82801JI (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card-1: Intel 82574L Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 3000 bus-ID: 04:00.0
           IF: ens1 state: down mac: <filter>
           Card-2: Broadcom Limited NetXtreme BCM5755 Gigabit Ethernet PCIE
           driver: tg3 v: 3.137 bus-ID: 05:00.0
           IF: ens5 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 570.0GB (2.1% used)
           ID-1: /dev/sda model: WDC_WD1600HLFS size: 160.0GB
           ID-2: /dev/sdb model: WDC_WD2500AAJS size: 250.0GB
           ID-3: /dev/sdc model: WDC_WD1600HLFS size: 160.0GB
Partition: ID-1: / size: 30G used: 7.0G (25%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 114G used: 893M (1%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 4.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A gpu: 0.0:56C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 215 Uptime: 6:53 Memory: 1071.3/16032.0MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
uno@labonline:~$ 

Re: MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 12:30 am
by MrEen
See if the last paragraph here helps.

Re: MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 5:54 am
by JeremyB
You could try

Code: Select all

echo -e "connect MACADDRESS\n quit"|bluetoothctl

Re: MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 4:27 pm
by all41
Hello again MrEen,
The referenced solution depends on bluez-utils whcih is not a repository package for Mint 19,
but may have been an imbedded solution for 17.x series.
Thank you for your Mint support and response.
@JeremyB
Yes that is the mitigation I was looking for. I added it to a growing startup script and it does the trick *.*
Perhaps this is the last little niggle to be expelled. Thank you for your Mint support--you're the man!

Re: [SOLVED] MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 4:46 pm
by MrEen
Hi all41. Glad you're issue is resolved! From further research it appears bluez-utils was replaced with/by bluez, but who cares if you have a working solution. :D

Re: [SOLVED] MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 5:37 pm
by all41
I was using a bluez-tools command to connect in 17.3.
That package is also no longer offered in the Tara repositories.
Ya gotta go with the flow--right? :wink:

Re: MInt 19 bluetooth problems

Posted: Sat Jun 23, 2018 7:03 pm
by all41
all41 wrote:
Sat Jun 23, 2018 4:27 pm

Perhaps this is the last little niggle to be expelled.
I was wrong---another more serious problem has reared it's ugly head. See:
viewtopic.php?f=143&t=270551&start=20#p1484207

Re: [SOLVED] MInt 19 bluetooth problems

Posted: Sun Jul 22, 2018 10:06 pm
by MikeLieberman
Just a note, as my BT mouse problem with Mint 19 is a little different. I have Bluz and Blueman installed. My mouse will alternately shows connected or not... but even when it shows connected, it doesn't work. It worked just find as of 18.3... but not now.

There is more of a BT problem than a simple missing library in Mint 19. For me, I just gave up and am using a non-BT wireless mouse and burning a USB port in the process. It's not the best, but not the end of the world either.

Re: [SOLVED] MInt 19 bluetooth problems

Posted: Mon Nov 12, 2018 6:06 am
by FireHeart2K
Simle fix using these steps:

Step 1:

Code: Select all

sudo apt-get remove blueberry
Step 2:

Code: Select all

sudo apt-get remove bluez-tools
(If you don't have this installed then skip step 2)

Step 3:

Code: Select all

sudo apt-get install blueberry
Step 4:

Code: Select all

sudo apt-get install bluez-tools