What happened to smb-share in Mint 19

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
GeBakker
Level 1
Level 1
Posts: 4
Joined: Sun Jul 13, 2014 2:11 pm

What happened to smb-share in Mint 19

Post by GeBakker » Thu Jul 26, 2018 11:17 am

I use a program called Freefilesync it can be used to sync files between folders within a computer but also in the LAN. It used to get connection information of attached devices under Linux Mint 18.3 in the LAN from /run/user/1000/gvfs/smb-share:server=fritz-nas,share=fritz.nas

In Linux Mint 19 there is no smb-share information in the /run/user/1000/gvfs/ folder, so Freefilesync is not able to detect the LAN devices, Nemo has no problem. Freefilesync works perfectly well in the same LAN on my Lubuntu 18.04 Laptop.

Is this a Mint 19 bug?

Gaugamela
Level 1
Level 1
Posts: 36
Joined: Wed Dec 21, 2011 11:59 am

Re: What happened to smb-share in Mint 19

Post by Gaugamela » Thu Jul 26, 2018 11:46 am

It's an Ubuntu 18.04 bug... And as that is the base of Mint 19, it also affects it.

altair4
Level 19
Level 19
Posts: 9284
Joined: Tue Feb 03, 2009 10:27 am

Re: What happened to smb-share in Mint 19

Post by altair4 » Thu Jul 26, 2018 1:56 pm

I'm confused by your post.

I have no idea what FreeFileSync is so I downloaded it ( 10.2 ) and ran it - on Mint 19. I don't know how to use it but when I select the browse button I can clearly see the share I mounted through Nemo ( public on gort.local ):
FreeFileSync.png
If you run the following command you do not get a list of the mounted shares?

Code: Select all

ls -l /run/user/1000/gvfs
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

GeBakker
Level 1
Level 1
Posts: 4
Joined: Sun Jul 13, 2014 2:11 pm

Re: What happened to smb-share in Mint 19

Post by GeBakker » Fri Jul 27, 2018 9:36 am

Altair4 thank you for your reaction.
I installed Freefilesync on a laptop with Mint 19, created some shares and it actually worked
ge@ge-Lenovo-E51-80:~$ ls -l /run/user/1000/gvfs
total 0
drwx------ 1 ge ge 0 jul 26 17:36 'smb-share:server=thuis1.local,share=opnames'
drwx------ 1 ge ge 0 jul 26 17:20 'smb-share:server=thuis1,share=downloads'

It is not as I suggested a Mint 19 bug. However the problem with my desktopcomputer persists.

rui no onna
Level 4
Level 4
Posts: 241
Joined: Thu Jul 19, 2018 4:18 pm

Re: What happened to smb-share in Mint 19

Post by rui no onna » Fri Jul 27, 2018 10:17 am


altair4
Level 19
Level 19
Posts: 9284
Joined: Tue Feb 03, 2009 10:27 am

Re: What happened to smb-share in Mint 19

Post by altair4 » Fri Jul 27, 2018 12:20 pm

Now I'm more confused.

From the Mint19 desktop open a terminal and run this command - if that is the correct server name and share of your nas:

Code: Select all

gio mount smb://fritz-nas/fritz.nas
If it mounted successfully it will just come back to the prompt in the terminal. Then see it the mount point was created:

Code: Select all

ls -l /run/user/1000/gvfs
Any error messages in any of that?

I'm trying to figure out if you can't access the nas at all from the desktop or if this is a FreeFileSync specific problem. I cannot tell that from your posts.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

GeBakker
Level 1
Level 1
Posts: 4
Joined: Sun Jul 13, 2014 2:11 pm

Re: What happened to smb-share in Mint 19

Post by GeBakker » Tue Jul 31, 2018 11:19 am

Thank you for your reaction.
I was getting nowhere so I installed Mint 19 anew and now the problem is solved

GeBakker
Level 1
Level 1
Posts: 4
Joined: Sun Jul 13, 2014 2:11 pm

Re: What happened to smb-share in Mint 19

Post by GeBakker » Tue Jul 31, 2018 11:28 am

Thank you for your reaction.
I was getting nowhere so I installed Mint 19 anew and now the problem is solved

I could actually connect to the Fritznas with Nemo but not with Freefilesync and the ls -l /run/user/1000/gvfs did not any connection only total 0

bpeary
Level 1
Level 1
Posts: 34
Joined: Tue Dec 28, 2010 7:11 am

Re: What happened to smb-share in Mint 19

Post by bpeary » Wed Aug 01, 2018 4:32 pm

rui no onna wrote:
Fri Jul 27, 2018 10:17 am
Perhaps try the tweak noted here:
https://www.dedoimedo.com/computers/ubu ... hares.html
Worked for me -- I could connect, but read-only, until I applied this workaround. Just for one-stop shopping, the workaround was to edit the samba config file/etc/samba/smb.conf as root, and add the following line anywhere (preferably with an explanatory comment):

client max protocol = NT1

Which has something to do with relaxing the over-stringent security rules in newer samba versions.

altair4
Level 19
Level 19
Posts: 9284
Joined: Tue Feb 03, 2009 10:27 am

Re: What happened to smb-share in Mint 19

Post by altair4 » Wed Aug 01, 2018 5:37 pm

bpeary wrote:
Wed Aug 01, 2018 4:32 pm
Just for one-stop shopping, the workaround was to edit the samba config file/etc/samba/smb.conf as root, and add the following line anywhere (preferably with an explanatory comment):

client max protocol = NT1

Which has something to do with relaxing the over-stringent security rules in newer samba versions.
This has nothing to do with samba imposing stricter security rules.
Samba did that so the smb client could connect to a Win10 box.

Samba made a very simple change to the default client protocols by setting the max to SMB3.11. The samba client will negotiate with the server to determine the best smb dialect to use. The highest level it would go before was NT1. Now it will go all the way up to SMB3.

It did that for a reason. Win10 disables SMB1 on the server side so the Linux client would be incapable of connecting to it if "client max protocol" was set to NT1 ( SMB1 ). Setting the max to SMB3 fixes that. It does have an unfortunate side affect however. It disables network browsing for hosts by their netbios name.

I warned you people about this a year ago: Samba Without SMB1. and again even before Min19 was released

And none of this has anything to do with this topic and the user's unfortunate symptoms.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”