Page 1 of 1

What happened to smb-share in Mint 19

Posted: Thu Jul 26, 2018 11:17 am
by GeBakker
I use a program called Freefilesync it can be used to sync files between folders within a computer but also in the LAN. It used to get connection information of attached devices under Linux Mint 18.3 in the LAN from /run/user/1000/gvfs/smb-share:server=fritz-nas,share=fritz.nas

In Linux Mint 19 there is no smb-share information in the /run/user/1000/gvfs/ folder, so Freefilesync is not able to detect the LAN devices, Nemo has no problem. Freefilesync works perfectly well in the same LAN on my Lubuntu 18.04 Laptop.

Is this a Mint 19 bug?

Re: What happened to smb-share in Mint 19

Posted: Thu Jul 26, 2018 11:46 am
by Gaugamela
It's an Ubuntu 18.04 bug... And as that is the base of Mint 19, it also affects it.

Re: What happened to smb-share in Mint 19

Posted: Thu Jul 26, 2018 1:56 pm
by altair4
I'm confused by your post.

I have no idea what FreeFileSync is so I downloaded it ( 10.2 ) and ran it - on Mint 19. I don't know how to use it but when I select the browse button I can clearly see the share I mounted through Nemo ( public on gort.local ):
FreeFileSync.png
If you run the following command you do not get a list of the mounted shares?

Code: Select all

ls -l /run/user/1000/gvfs

Re: What happened to smb-share in Mint 19

Posted: Fri Jul 27, 2018 9:36 am
by GeBakker
Altair4 thank you for your reaction.
I installed Freefilesync on a laptop with Mint 19, created some shares and it actually worked
ge@ge-Lenovo-E51-80:~$ ls -l /run/user/1000/gvfs
total 0
drwx------ 1 ge ge 0 jul 26 17:36 'smb-share:server=thuis1.local,share=opnames'
drwx------ 1 ge ge 0 jul 26 17:20 'smb-share:server=thuis1,share=downloads'

It is not as I suggested a Mint 19 bug. However the problem with my desktopcomputer persists.

Re: What happened to smb-share in Mint 19

Posted: Fri Jul 27, 2018 10:17 am
by rui no onna

Re: What happened to smb-share in Mint 19

Posted: Fri Jul 27, 2018 12:20 pm
by altair4
Now I'm more confused.

From the Mint19 desktop open a terminal and run this command - if that is the correct server name and share of your nas:

Code: Select all

gio mount smb://fritz-nas/fritz.nas
If it mounted successfully it will just come back to the prompt in the terminal. Then see it the mount point was created:

Code: Select all

ls -l /run/user/1000/gvfs
Any error messages in any of that?

I'm trying to figure out if you can't access the nas at all from the desktop or if this is a FreeFileSync specific problem. I cannot tell that from your posts.

Re: What happened to smb-share in Mint 19

Posted: Tue Jul 31, 2018 11:19 am
by GeBakker
Thank you for your reaction.
I was getting nowhere so I installed Mint 19 anew and now the problem is solved

Re: What happened to smb-share in Mint 19

Posted: Tue Jul 31, 2018 11:28 am
by GeBakker
Thank you for your reaction.
I was getting nowhere so I installed Mint 19 anew and now the problem is solved

I could actually connect to the Fritznas with Nemo but not with Freefilesync and the ls -l /run/user/1000/gvfs did not any connection only total 0

Re: What happened to smb-share in Mint 19

Posted: Wed Aug 01, 2018 4:32 pm
by bpeary
rui no onna wrote:
Fri Jul 27, 2018 10:17 am
Perhaps try the tweak noted here:
https://www.dedoimedo.com/computers/ubu ... hares.html
Worked for me -- I could connect, but read-only, until I applied this workaround. Just for one-stop shopping, the workaround was to edit the samba config file/etc/samba/smb.conf as root, and add the following line anywhere (preferably with an explanatory comment):

client max protocol = NT1

Which has something to do with relaxing the over-stringent security rules in newer samba versions.

Re: What happened to smb-share in Mint 19

Posted: Wed Aug 01, 2018 5:37 pm
by altair4
bpeary wrote:
Wed Aug 01, 2018 4:32 pm
Just for one-stop shopping, the workaround was to edit the samba config file/etc/samba/smb.conf as root, and add the following line anywhere (preferably with an explanatory comment):

client max protocol = NT1

Which has something to do with relaxing the over-stringent security rules in newer samba versions.
This has nothing to do with samba imposing stricter security rules.
Samba did that so the smb client could connect to a Win10 box.

Samba made a very simple change to the default client protocols by setting the max to SMB3.11. The samba client will negotiate with the server to determine the best smb dialect to use. The highest level it would go before was NT1. Now it will go all the way up to SMB3.

It did that for a reason. Win10 disables SMB1 on the server side so the Linux client would be incapable of connecting to it if "client max protocol" was set to NT1 ( SMB1 ). Setting the max to SMB3 fixes that. It does have an unfortunate side affect however. It disables network browsing for hosts by their netbios name.

I warned you people about this a year ago: Samba Without SMB1. and again even before Min19 was released

And none of this has anything to do with this topic and the user's unfortunate symptoms.