Page 1 of 1

Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 4:57 pm
by MintyPhilip
Hey all

I've installed Mint 19 Mate edition, everything seems to work brilliantly except for Bluetooth.
Blueberry, the default config tool wasn't much help. it would see my mouse but wouldn't pair. So I uninstalled that and installed Blueman which after a few tries eventually paired with my mouse (yay!)

The trouble now is that it drops the connection and will not reconnect. For example, if I reboot the system the mouse is instantly connected while on the login screen, but once logged into the desktop it immediately drops the connection and refuses to reconnect.

I was previously on Manjaro KDE edition and Bluetooth was flawless so I know my mouse isn't the issue. Any help is really appreciated, its completely doing my head in.

Thanks in advance



if it helps the output from (lspci -nnk | grep -iA3 net && lsusb) | nc termbin.com 9999


00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
Subsystem: Lenovo 82579LM Gigabit Network Connection (Lewisville) (ThinkPad T520) [17aa:21ce]
Kernel driver in use: e1000e
Kernel modules: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 04)
--
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 001 Device 004: ID 13fe:4200 Kingston Technology Company Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:00 pm
by JeremyB
What is the result for

Code: Select all

cat /sys/bus/usb/devices/1-3/power/control

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:01 pm
by MintyPhilip
its says no such file or directory?

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:11 pm
by JeremyB
Result for

Code: Select all

ls /sys/bus/usb/devices; lsusb -t

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:15 pm
by MintyPhilip

Code: Select all

1-0:1.0
1-1
1-1.1
1-1:1.0
1-1.1:1.0
1-1.4
1-1.4:1.0
1-1.4:1.1
1-1.4:1.2
1-1.4:1.3
2-0:1.0
2-1
2-1:1.0
usb1
usb2
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 1: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 4: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 2, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 4: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 3, Class=Application Specific Interface, Driver=, 12M

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:22 pm
by JeremyB

Code: Select all

cat /sys/bus/usb/devices/1-1.4:1.3/power/control
But it could change port

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:26 pm
by MintyPhilip
Thanks for helping me out i really appreciate it.

I'm not sure what you mean by change port?

i put

Code: Select all

cat /sys/bus/usb/devices/1-1.4:1.3/power/control
into the terminal and again it says no such file or directory

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:32 pm
by JeremyB
Lets try another way

Code: Select all

sudo touch /etc/udev/rules.d/usb-power.rules
xed admin:///etc/udev/rules.d/usb-power.rules
Paste this line as one line into the editor

Code: Select all

ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0a5c", ATTR{idProduct}=="217f", TEST=="power/control", ATTR{power/control}="on"
Save, exit editor and reboot

Re: Bluetooth not working on Thinkpad

Posted: Sun Aug 26, 2018 5:49 pm
by MintyPhilip
OK I've done that but the issue remains, though its slightly different so its progress of a kind I guess

before it would connect at the login screen, and drop once logged in.

now it doesn't connect at the login screen, it does connect on login after a few seconds but once i stop moving the pointer about the screen it drops again.

if i try to reconnect from the bluetooth indicator there's a notification popup that says "connection failed, input/output error" which didn't happen before?

Re: Bluetooth not working on Thinkpad

Posted: Mon Aug 27, 2018 8:48 am
by MintyPhilip
OK so I've booted up a live XFCE session to see if the issue was with the Mate setup but it was exactly the same situation, seems the XFCE desktop uses the same bluetooth apps as Mate

Considering bluetooth worked perfectly while I was on Manjaro using KDE i decided to install Plasma desktop on Mint. low and behold bluetooth worked perfectly first time. so it seems its not a distro issue rather a DE issue.