Mint 19 - System-config-samba GUI not working

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
ec91066
Level 1
Level 1
Posts: 31
Joined: Wed Mar 26, 2014 7:14 pm

Mint 19 - System-config-samba GUI not working

Post by ec91066 » Fri Sep 07, 2018 8:44 am

Hello all,

Samba is a mess in Mint 19 Cinnamon... I've been using Mint since version 15 and everything worked out of the box until this new version.

I've been trying to share a folder in Mint19 and, fist, I tried to do it through Nemo's samba integration. Doesn't work... I can't access that share from my laptop wich is running MInt also - Connection refused after logging in with my username and password (I feel like i'm using some Windows).

Then, I installed System-config-samba GUI to better configure this share but i can't access the GUI. It doesn't show in Administration/System Definitions and I can't find a way to run it through the command line.

Time to enter hack mode...

Any help appreciated. Thanks.

canmintguy
Level 1
Level 1
Posts: 1
Joined: Sun Sep 09, 2018 1:47 pm
Location: Toronto, Canada

Re: Mint 19 - System-config-samba GUI not working

Post by canmintguy » Sun Sep 09, 2018 1:57 pm

Hello,

I installed Linux Mint 19 yesterday and having the exact same problem with Samba and Samba GUI. I was about to reinstall Mint, but instead booted using the live installation USB. Then I checked Software Manager in the live session and it showed Samba was installed. Next, I installed the System-config-samba GUI. According to Software Manager, both Samba and System-config-samba are both installed. However, Samba GUI will not load.

Anyone know of any hacks around this issue?

Thanks!

altair4
Level 19
Level 19
Posts: 9320
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 19 - System-config-samba GUI not working

Post by altair4 » Sun Sep 09, 2018 2:21 pm

@ec91066, You really have two questions:
I've been trying to share a folder in Mint19 and, fist, I tried to do it through Nemo's samba integration. Doesn't work... I can't access that share from my laptop wich is running MInt also - Connection refused after logging in with my username and password (I feel like i'm using some Windows).
It sounds like you didn't add the user name to the samba password database:

Code: Select all

sudo smbpasswd -a your-user-name
If you already did that we need more info. Please post the output of the following commands:

Code: Select all

net usershare info --long

Code: Select all

testparm -s
Then, I installed System-config-samba GUI to better configure this share but i can't access the GUI. It doesn't show in Administration/System Definitions and I can't find a way to run it through the command line.
system-config-samba is abandoned software. I really don't know why Ubuntu still has it in the repository since I don't think they have any intention of fixing it.

Anyhoo, add a missing file - this will create an empty file:

Code: Select all

sudo touch /etc/libuser.conf
Then run it with this command:

Code: Select all

sudo -H system-config-samba
Keep in mind that it's days are numbered: https://bugs.launchpad.net/ubuntu/+sour ... ug/1740419

I would suggest you don't use it if you plan on using it together with the shares you created in Nemo. They are both samba shares but they can conflict with each other if used on the same folder.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

ec91066
Level 1
Level 1
Posts: 31
Joined: Wed Mar 26, 2014 7:14 pm

Re: Mint 19 - System-config-samba GUI not working

Post by ec91066 » Tue Sep 11, 2018 4:19 pm

altair4, thanks for your reply.

I uninstalled system-config-samba. If it is abandoned software, better leave it behind.

I followed your instructions and added my username to the samba password database with no results.
Here are outputs to the commands you referred.
fernando@S5210PT-Mint19:~$ net usershare info --long
Unknown parameter encountered: "password level"
Ignoring unknown parameter "password level"
Unknown parameter encountered: "update encrypted"
Ignoring unknown parameter "update encrypted"
Unknown parameter encountered: "password level"
Ignoring unknown parameter "password level"
Unknown parameter encountered: "update encrypted"
Ignoring unknown parameter "update encrypted"
[OVA]
path=/media/fernando/Dropbox/OVA
comment=
usershare_acl=Everyone:F,
guest_ok=n

[Público]
path=/home/fernando/Público
comment=
usershare_acl=Everyone:F,
guest_ok=n
fernando@S5210PT-Mint19:~$ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "null passwords" option is deprecated
Unknown parameter encountered: "password level"
Ignoring unknown parameter "password level"
Unknown parameter encountered: "update encrypted"
Ignoring unknown parameter "update encrypted"
WARNING: The "idmap uid" option is deprecated
WARNING: The "idmap gid" option is deprecated
Processing section "[homes]"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[printers]"
Processing section "[pdf-documents]"
Processing section "[pdf-printer]"
Loaded services file OK.
WARNING: socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
SO_RCVLOWAT
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set 'socket options' you are overriding those
settings.
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the 'socket options' correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
small changes and test the effect before making any
large changes.

WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE

# Global parameters
[global]
add group script = /usr/sbin/groupadd '%g'
add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c 'Samba Machine Account' -s /dev/null -M '%u'
add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null '%u'
add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null -g '%g' '%u'
allow trusted domains = No
bind interfaces only = Yes
client schannel = No
client signing = No
client use spnego = No
delete group script = /usr/sbin/groupdel '%g'
delete user from group script = /usr/sbin/userdel '%u' '%g'
delete user script = /usr/sbin/userdel '%u'
dns proxy = No
domain master = No
guest account = smbguest
idmap gid = 16777216-33554431
idmap uid = 16777216-33554431
interfaces = 127.0.0.1/8 192.168.0.0/24
local master = No
log file = /var/log/samba/samba.log
logon drive = m:
logon home = \\%L\homes\%u
logon path = \\%L\profiles\%u
logon script = %G.bat
machine password timeout = 120
max log size = 1000
name resolve order = wins lmhosts bcast
netbios name = SAMBA24
obey pam restrictions = Yes
os level = 33
passwd chat = *New*password* %n\n *ReType*new*password* %n\n *passwd*changed*\n
passwd chat timeout = 120
passwd program = /usr/bin/passwd '%u'
preferred master = No
printcap name = cups
remote announce = 192.168.0.255
remote browse sync = 192.168.0.255
security = USER
server schannel = No
server signing = No
server string = Samba file and print server
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
template shell = /dev/null
unix password sync = Yes
username level = 6
username map = /etc/samba/smbusers
winbind cache time = 360
winbind nested groups = No
winbind nss info = no
winbind separator = @
winbind trusted domains only = Yes
winbind use default domain = Yes
idmap config * : range = 16777216-33554431
idmap config * : backend = tdb
cups options = raw
follow symlinks = No
hosts allow = 127. 192.168.0.


[homes]
comment = Home Directories
locking = No
path = /home
read only = No
strict locking = No
valid users = %U


[netlogon]
comment = Network Logon Service
locking = No
path = /var/lib/samba/netlogon
strict locking = No


[profiles]
comment = User Profiles
create mask = 0600
directory mask = 0700
locking = No
path = /var/lib/samba/profiles
read only = No
strict locking = No


[printers]
browseable = No
comment = All Printers
locking = No
path = /var/spool/samba
printable = Yes
strict locking = No


[pdf-documents]
admin users = %U
comment = Converted PDF Documents
guest ok = Yes
locking = No
path = /var/lib/samba/pdf-documents
read only = No
strict locking = No


[pdf-printer]
comment = PDF Printer Service
guest ok = Yes
lpq command =
path = /tmp
printable = Yes
print command = /usr/bin/gadmin-samba-pdf %s %u
printing = bsd
use client driver = Yes
fernando@S5210PT-Mint19:~$

altair4
Level 19
Level 19
Posts: 9320
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 19 - System-config-samba GUI not working

Post by altair4 » Tue Sep 11, 2018 5:09 pm

This is not your fault. You apparently installed something called gadmin-samba. It has no place in the repositories of modern operating systems. It is unsupportable at this point so I would suggest you restart:

There is a backup factory-fresh copy of smb.conf that you can use to replace the one you have:

Rename your current smb.conf:

Code: Select all

sudo mv /etc/samba/smb.conf /etc/samba/smb.confORIG
Copy the backup to the working location:

Code: Select all

sudo cp -a /usr/share/samba/smb.conf /etc/samba/
Then restart smbd:

Code: Select all

sudo service smbd restart
Your samba usershares look like this:
[OVA]
path=/media/fernando/Dropbox/OVA
comment=
usershare_acl=Everyone:F,
guest_ok=n

[Público]
path=/home/fernando/Público
comment=
usershare_acl=Everyone:F,
guest_ok=n
Nothing wrong with that as long as you understand that only fernando will be able to access the [OVA] share. So make sure that user is in the samba password database:

Code: Select all

sudo smbpasswd -a fernando
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

ec91066
Level 1
Level 1
Posts: 31
Joined: Wed Mar 26, 2014 7:14 pm

Re: Mint 19 - System-config-samba GUI not working

Post by ec91066 » Wed Sep 12, 2018 12:36 pm

Many thanks, altair4.

Samba working now.

Cheers.

RML
Level 1
Level 1
Posts: 5
Joined: Thu Jan 08, 2015 5:12 pm

Re: Mint 19 - System-config-samba GUI not working

Post by RML » Tue Oct 30, 2018 8:12 pm

Ref: viewtopic.php?t=239673
Some folks install a package: system-config-samba as a GUI to administer Samba. That package hasn't been updated for years so it will not run until you do this first:

Code: Select all

sudo touch /etc/libuser.conf

Post Reply

Return to “Other networking topics”