LM18.3 can't see LM19[solved]

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
User avatar
AndyMH
Level 5
Level 5
Posts: 717
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

LM18.3 can't see LM19[solved]

Post by AndyMH » Tue Sep 11, 2018 9:11 am

Three computers, one T430 running 18.3 (my daily driver), one T430 running LM19 and a desktop running LM19.
  • The LM18.3 laptop can see the shares I've set up on the two LM19 machines.
  • The two LM19 machines can see each other.
  • Neither LM19 machine can see the LM18.3 machine.
  • All three can see my synology NAS.
Each machine has a single shared folder set up. When setting up the shares, additional samba stuff was installed on all machines.

I'm sure it's simple, there is no windows involved, only linux mint. How do I get the LM19 machines to see the LM18.3 laptop?

Not essential, because once I'm happy with LM19 on the other two, I'll be migrating my daily driver to LM19. But surely, this sort of stuff should work 'out of the box'.
Last edited by AndyMH on Tue Sep 11, 2018 1:31 pm, edited 1 time in total.
Homebrew i5-8400+GTX1080 Cinnamon 19, Thinkpad T430 i7-3632 Cinnamon 19, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

altair4
Level 19
Level 19
Posts: 9273
Joined: Tue Feb 03, 2009 10:27 am

Re: LM18.3 can't see LM19

Post by altair4 » Tue Sep 11, 2018 9:45 am

The LM18.3 laptop can see the shares I've set up on the two LM19 machines.

The two LM19 machines can see each other.

Neither LM19 machine can see the LM18.3 machine
Everyone can see the LM19 samba hosts because Ubuntu read the installation manual for Samba when it set things up in Ubuntu 18.04 ( Mint19 ). They did not in Ubuntu 16.04 ( Mint18 ).

You can force Mint18 do what Mint19 does by going into Mint18 and:

[1] Create a file at: /etc/avahi/services/samba.service

[2] Add this to it:

Code: Select all

<?xml version="1.0" standalone='no'?>
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<service-group>
   <name replace-wildcards="yes">%h SMB</name> ## Display Name
   <service>
       <type>_smb._tcp</type>
       <port>445</port>
   </service>
</service-group>
[3] You shouldn't need to do this but just in case restart avahi:

Code: Select all

sudo service avahi-daemon restart
Your Mint19 machines should be able to see your mint18 machine as Mint18-host-name SMB
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
AndyMH
Level 5
Level 5
Posts: 717
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: LM18.3 can't see LM19[solved]

Post by AndyMH » Tue Sep 11, 2018 1:33 pm

Many thanks, worked, didn't need to restart avahi. Thought as the 'resident' samba guru you would respond. Probably saved me hours trawling the internet.
Homebrew i5-8400+GTX1080 Cinnamon 19, Thinkpad T430 i7-3632 Cinnamon 19, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

Post Reply

Return to “Other networking topics”