IPv6 privacy extensions - not working: reset every few seconds

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
chris42
Level 1
Level 1
Posts: 18
Joined: Tue Jul 26, 2016 6:02 pm

IPv6 privacy extensions - not working: reset every few seconds

Post by chris42 » Mon Sep 17, 2018 6:11 am

Hi there,
On my system (Mint 19 Cinnamon) privacy extensions for IPv6 are activated and I successfully get a global temporary dynamic IPv6.

However this IPv6 does not change. The lifetime is being reset every few seconds back to 14399. Then counts down for a few seconds and gets reset.
Hence the IPv6 never expires and a new one is not created. Basically rendering the extensions useless.

Anyone experiencing the same? Any ideas how to debug or how to solve?

Thanks
Chris

EDIT: missed the "temporary" in the description... Which is quite important for the case ;-)
Last edited by chris42 on Mon Sep 17, 2018 7:10 am, edited 1 time in total.

User avatar
catweazel
Level 17
Level 17
Posts: 7542
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: IPv6 privacy extensions - not working: reset every few seconds

Post by catweazel » Mon Sep 17, 2018 6:33 am

chris42 wrote:
Mon Sep 17, 2018 6:11 am
Anyone experiencing the same? Any ideas how to debug or how to solve?
https://major.io/2016/04/17/enable-ipv6 ... rkmanager/

See if that helps.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

chris42
Level 1
Level 1
Posts: 18
Joined: Tue Jul 26, 2016 6:02 pm

Re: IPv6 privacy extensions - not working: reset every few seconds

Post by chris42 » Mon Sep 17, 2018 7:08 am

Yes, was on that page already when trying to activate privacy extensions. For some reason my system is ignoring the sysctl configuration completely. I needed to set it in the network manager per connection. (This seems to be another bug?).

However the countdown for the addresses get reset. I figured it gets reset with every router advertisement.

chris42
Level 1
Level 1
Posts: 18
Joined: Tue Jul 26, 2016 6:02 pm

Re: IPv6 privacy extensions - not working: reset every few seconds

Post by chris42 » Mon Sep 17, 2018 7:28 am

I would guess this is a bug somewhere in the networking. The router advertisements for temporary addresses should be ignored and the lifetime just be counted down.

However what is the right module to report a bug to?

chris42
Level 1
Level 1
Posts: 18
Joined: Tue Jul 26, 2016 6:02 pm

[Solved] Activiate IPv6 privacy extensions on Tara (also after upgrade)

Post by chris42 » Mon Sep 17, 2018 8:04 am

Just a note, if you are trying to activate IPv6 privacy extensions under Tara (or you are coming from pre Ubuntu 17.04 versions).

As Ubuntu switched to nplan for configuration, there is a Bug https://bugs.launchpad.net/ubuntu/+sour ... ug/1750392, which ignores the sysctl settings.

You need to do the following:
1. sudo nano /etc/netplan/60-ipv6.yaml
2. add: ip6-privacy: true

chris42
Level 1
Level 1
Posts: 18
Joined: Tue Jul 26, 2016 6:02 pm

Re: IPv6 privacy extensions - not working: reset every few seconds

Post by chris42 » Mon Sep 17, 2018 8:25 am

Huh? What happened here?

So to clean that up: The "[Solved] Activiate IPv6 privacy extensions on Tara (also after upgrade)" post that just appeared here in the thread has only remotely to do with the topic here. I did this in an extra thread, not to confuse ppl.

It is an explanation on how to activate privacy extensions in the first place, as here in the thread already outdated information were posted.

The reset of lifetime for the IP however is separate of this.

Post Reply

Return to “Other networking topics”