Samba running two sessions?

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
AnOrange
Level 1
Level 1
Posts: 3
Joined: Thu Sep 20, 2018 8:55 am

Samba running two sessions?

Post by AnOrange » Thu Sep 20, 2018 9:12 am

Hello all. I'm a long time Mint user, never had problems that I couldn't resolve (thanks to this forum!) and I've just upgraded my PC to 19. I have a number of computers on my home network and successfully use Samba for file sharing (including with an old Buffulo NAS box) Samba has never been a problem for me (touch wood!) and I'm now quite a dab hand at sorting out issues (tbh, I find Samba pretty straight forward as long as you keep it simple) However, this little problem is baffling me....

My new Tara PC appears twice on a network browse - both with "(File Sharing)" appended to the host name (I've not seen that before) It appears this way on all networked PCs. File sharing works as it should, no issues there, it's just this weird appearing twice thing - it's as if two samba sessions are running. If I do 'sudo service smbd stop', both 'host name + "(File Sharing)" entries go to be replaced by simply the host name. Obviously, the host is then no longer browseable . 'sudo service smbd start' sees both entries reappear and the host is again browseable.

sudo service smbd status shows...

● smbd.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: ena
Active: active (running) since Thu 2018-09-20 15:09:58 CEST; 2s ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Main PID: 4620 (smbd)
Status: "smbd: ready to serve connections..."
Tasks: 4 (limit: 4621)
CGroup: /system.slice/smbd.service
├─4620 /usr/sbin/smbd --foreground --no-process-group
├─4622 /usr/sbin/smbd --foreground --no-process-group
├─4623 /usr/sbin/smbd --foreground --no-process-group
└─4624 /usr/sbin/smbd --foreground --no-process-group

Sep 20 15:09:58 Gerard systemd[1]: Starting Samba SMB Daemon...
Sep 20 15:09:58 Gerard systemd[1]: Started Samba SMB Daemon.

Can someone point me in the direction of resolving this intrigue? Thanks :)

Edit: attached screen shot shows what I mean (Gerard is the new Tara PC)
Attachments
samba_browse.png

AnOrange
Level 1
Level 1
Posts: 3
Joined: Thu Sep 20, 2018 8:55 am

Re: Samba running two sessions?

Post by AnOrange » Mon Oct 15, 2018 10:08 am

Sorted it, using Webmin, as it makes it easier to configure smb.conf

I changed the 'default service' in the [global] settings

Thanks for all your help :wink:

User avatar
BG405
Level 7
Level 7
Posts: 1563
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Samba running two sessions?

Post by BG405 » Thu Oct 18, 2018 9:47 pm

Thanks for taking the time to post your solution, and I apologize myself and on behalf of the members on here for not spotting your original post. Unfortunately, I've seen that it happens all too often .. I, for one, check the "New Posts" on average once daily; i suspect many others do also, but posts inevitably still get overlooked, or simply not seen by someone who feels they can help.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB305 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

AnOrange
Level 1
Level 1
Posts: 3
Joined: Thu Sep 20, 2018 8:55 am

Re: Samba running two sessions?

Post by AnOrange » Mon Dec 03, 2018 2:19 am

Late update.... I reverted back to 18 in the end.

After rebooting (on 19), I had the 2 'File Sharing' services back again. Service restart (sudo service smbd restart) didn't resolve but restarting via Webmin did. I could not find a reason nor cause for the 2 services... so I gave up and it bugged me so that I went back to 18.

altair4
Level 19
Level 19
Posts: 9315
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba running two sessions?

Post by altair4 » Mon Dec 03, 2018 7:40 am

You will likely have to remain with Mint18 for quite some time.

Ubuntu finally enabled mDNS in samba with Ubuntu 18.04 so when everything is working correctly your Mint19 machines will appear twice:

** Once using the deprecated netbios mechanism which resolves to smb://gerard

** And agin using mDNS which resolves to smb://gerard.local

It's not a bug it's a feature.

Two different options in smb.conf control how these run: multicast dns register and disable netbios
I wouldn't recommend messing with either but that's me.

For the typical Mint user this probably isn't an issue since netbios "discovery" is broken in Mint unless the user adds client max protocol = NT1 to his smb.conf
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”