DNS resolution fails after disconnecting from VPN

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
verge
Level 1
Level 1
Posts: 1
Joined: Thu Oct 11, 2018 6:13 pm

DNS resolution fails after disconnecting from VPN

Post by verge » Thu Oct 11, 2018 6:22 pm

Hello. I'm running LM 19. My work uses a PPTP VPN. I have a vpn connection setup through the network icon thingy on my taskbar. My networking works fine before connecting to the VPN, and even during the VPN session. When I disconnect from the VPN though, my DNS stops working. For example, after disconnecting I can ping 8.8.8.8, but not ping google.com. To solve the issue I've been using dhclient to get a new IP address from my home router, and then DNS starts working fine once again.

I'm not sure which logs I should look at or how to troubleshoot this issue. Any ideas/thoughts would be appreciated.

User avatar
phd21
Level 17
Level 17
Posts: 7225
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: DNS resolution fails after disconnecting from VPN

Post by phd21 » Thu Oct 11, 2018 8:11 pm

HI verge,

Not sure if this will help or not, but do you have the "resolvconf" and "dsnmasq" installed? Restart your computer afterward.

Code: Select all

sudo apt install resolvconf dsnmasq easy-rsa

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Gruppo Sportivo
Level 1
Level 1
Posts: 47
Joined: Sun May 28, 2017 4:14 am
Location: Rotterdam

Re: DNS resolution fails after disconnecting from VPN

Post by Gruppo Sportivo » Fri Oct 12, 2018 4:32 am

verge wrote:
Thu Oct 11, 2018 6:22 pm
When I disconnect from the VPN though, my DNS stops working.
Is perhaps the Kill Switch and DNS protection enabled ??.
Linux Mint¨Tara¨19.064-bit Cinnamon 3.8.9&Raspberry Pi 3B+ OSMC

Post Reply

Return to “Other networking topics”