Can not browse Network Mint XFCE 19

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 46
Joined: Fri Sep 08, 2017 10:44 pm

Can not browse Network Mint XFCE 19

Post by brvcf »

Mint 19 XFCE Nothing listed in Thunar Network
On two Mint 18.3 XFCE computers all my Windows network computersshow up in Thunar under Network and I can access them whether Windows XP or Windows 10.

On Mint 19 XFCE 64 nothing shows up.

I followed the steps in HowTo: Samba Browsing Problems Checklist viewtopic.php?f=42&t=88146&start=0
[1] - yes same subnet
[2] - sudo service smbd and sudo service nmbd. The response indicated that Samba was not installed at all so I installed it. Then using software manager I compared which components were installed on 18.3 and 18 and it looked like the same packages in both 18 and 19.
[3] - hostname obviously no problem since network computers show up on 18.3
[4] - there is no name resolve order line in smb.conf in the working 18.3 or in 19
[5] - ufw is off in Mint. Firewall on Windows machines not blocking since i can access from Mint 18.3 (and other Windows).
[6] - workgroup = WORKGROUP
Next I looked at Mint 19 and Samba File Sharing Changes viewtopic.php?f=42&t=270442
Mint 19 as a Samba Client
[A] adding client max protocol = NT1 did nothing.

after I did all the above
smbtree shows all the shares but nothing shows up in Thunar file manager Network except the computer I ran the command on.

EDIT 10/18:
About a day after I wrote this, Thunar on Mint 18.3 also stopped seeing Windows network computers.

The next day just for the heck of it I tried adding client max protocol = NT1 to the Mint 19 PC and it worked this time. By the way, this includes seeing and being able to access a Windows 10 share, contrary to what Mint 19 and Samba File Sharing Changes viewtopic.php?f=42&t=270442 says. One thing I had done in the interim is reboot the 18.3 to Vista to run some Windows-only program. So I booted it back to Mint and still no Windows shares in Thunar. So just for the heck of it I booted it back to Vista again and found that Vista couldn't see the network shares either.

One other piece of information is that all this time I had my old trusty XP computer running. It never goes to sleep. So I assume it remains the Master Browser. There is also a Win10 PC on the network. It does go to sleep.

So it appears that there is more to this problem than just the Mint 18-19 samba/cifs configuration.

Any networking experts out there?
Level 1
Level 1
Posts: 32
Joined: Sun Mar 11, 2018 4:45 pm

Re: Can not browse Network Mint XFCE 19

Post by MatNieuw »

I had the same problem, with a Samba set up as standalone server. My Samba was set up to share a single partition to the network, and testparm showed it was.

smbclient -L pcname would give "tree connect failed: NT_STATUS_ACCESS_DENIED" (and adding -d 10 showed that it connected and authenticated OK but there was no share).
smbclient //pcname/sharename works, so Samba is doing its job.
smbtree showed nothing
thunar showed nothing.

In order to make the above work, I also had to enable the [home] share. Now all of the above work. If I comment out the home share, it doesn't work. Very repeatable.This seems to be a design error, why must Samba make available a home share before the tools will show other shares?

Mat Nieuwenhoven
User avatar
Level 11
Level 11
Posts: 3544
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Can not browse Network Mint XFCE 19

Post by lsemmens »

Fully mint Household
Out of my mind - please leave a message
Level 20
Level 20
Posts: 10259
Joined: Tue Feb 03, 2009 10:27 am

Re: Can not browse Network Mint XFCE 19

Post by altair4 »

How many machines are we talking about in your network? By my count it's 5 ( mint19 + 2 Mint18 + WinXP + Win10 )

For the Mint machines to see each other:

** For Mint19 nothing needs to be done.

** For Mint18:
[1] Create an avahi samba service file at /etc/avahi/services/samba.service

[2] Then copy and past the following into it:

Code: Select all

<?xml version="1.0" standalone='no'?>
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
   <name replace-wildcards="yes">%h SMB</name> ## Display Name
[3] And just in case restart avahi:

Code: Select all

sudo service avahi-daemon restart
That leaves the two Windows boxes. You stated that smbtree shows all of your windows hosts so name resolution is not a problem. My suggestion is to Bookmark them at the Host level.

Just enter in thunar smb://host-name-of-windows. When it opens up to list all the shares bookmark it at the host level.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
Post Reply

Return to “Other networking topics”