445 Port (Networking)

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
User avatar
jgcasanova
Level 1
Level 1
Posts: 7
Joined: Thu Jul 05, 2018 1:51 pm

445 Port (Networking)

Post by jgcasanova » Fri Nov 02, 2018 9:54 am

Hi everyone !

In the company where I work and for reasons to contain the expansion of a virus, they have blocked port 445. It turns out that through port 445 linux communicates with the windows servers, which affected me severely since I can not access servers Windows and shared folders to search or load information.

As I read in some internet sites, the other options to communicate with Windows is through ports 139 and 138, but I have not found information on how it is configured,

I thank whoever has the knowledge, to guide me on how to change port 445 by 139 or 138 for the communication of my Linux PC with Windows servers.

Thanks in advance.

altair4
Level 19
Level 19
Posts: 9320
Joined: Tue Feb 03, 2009 10:27 am

Re: 445 PORT (NETWORKING)

Post by altair4 » Fri Nov 02, 2018 11:03 am

Samba already uses port 139 ( even though it hasn't been used since Windows 2000 - maybe WinXP ). You can verify this yourself by running the following command:

Code: Select all

testparm -sv | grep "smb ports"
It should list both 445 and 139.

As far as 138 is concerned there is nothing in samba itself that prevents it from being used.

I don't quite understand the logic is disabling 445 ( newer ) for port 139 ( which is now considered deprecated ).

What version of Mint are you using?

This is just a guess on my part but I suspect the real problem is that your company disabled the SMB1 protocol dialect on those Windows servers for security reasons. If you are using Mint 19 as the client that should not be an issue but if you are using anything prior to that it will prevent you from gaining access. To allow older Mint machines access to SMB1-less servers edit /etc/samba/smb.conf and right under the workgroup = WORKGROUP line add this one:

Code: Select all

client max protocol = SMB3
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”