Mint-19 Nemo cannot see/mount samba shares

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
ricardo06
Level 1
Level 1
Posts: 12
Joined: Tue Dec 11, 2012 8:19 am

Mint-19 Nemo cannot see/mount samba shares

Post by ricardo06 » Mon Nov 05, 2018 12:52 pm

Hello I have 3 pc - One running Mint 19, one runnig Mint 18 and an old one with lxle. all in the same local network, all have samba installed. All of them have shared spaces declared from nemo or from the smb.conf file.
In Nemo, the PC with Mint 19, cannot "see" any of the shares that I declared. The two other PC can see and access all the shares.
On the PC with mint 19 :
- if I do a "smbtree", it detects the other samba servers with their correct names.
- if I hard write the adress smb://<name of PC with Mint18>/<a share name> in the nemo adress line then it mounts the space correctly
- If I do the same with the other lxle PC nothing is mounted
- if I do sudo smbclient -L <IP of PC with lxle> it says Connection to <IP adress> failed.(Error NT_STATUS_IO_TIMEOUT)

I can show more commands that I tried but the feeling that I have is that the PC with mint19 behaves as it had no "rights" to see the other ones, although it pings correctly both other.
I would greatly appreciate someone can Help me with this issue.
Many thanks
Richard

altair4
Level 19
Level 19
Posts: 9307
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint-19 Nemo cannot see/mount samba shares

Post by altair4 » Mon Nov 05, 2018 1:32 pm

Mint 19 and Samba File Sharing Changes: viewtopic.php?f=42&t=270442

Short Version: There are two ways to handle this issue.

The Windows Way: Edit /etc/samba/smb.conf on the Mint19 machine and add a line under the workgroup = WORKGROUP line:

Code: Select all

client max protocol = NT1
Then restart smbd: sudo service smbd restart
EDIT: I keep forgetting that it requires a reboot not a service restart

The Linux Way: : On all of the non-Mint19 machines add a file at /etc/avahi/services/samba.service with this content:

Code: Select all

<?xml version="1.0" standalone='no'?>
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<service-group>
   <name replace-wildcards="yes">%h SMB</name> ## Display Name
   <service>
       <type>_smb._tcp</type>
       <port>445</port>
   </service>
</service-group>
The lxle machine remains a mystery to me.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

ricardo06
Level 1
Level 1
Posts: 12
Joined: Tue Dec 11, 2012 8:19 am

Re: Mint-19 Nemo cannot see/mount samba shares [SOLVED]

Post by ricardo06 » Tue Nov 06, 2018 5:29 am

Many thanks, it worked perfectly.
By the way the Gufw firewall was on by default ,after a fresh install, on the lxle machine.
SO now I'am Happy !

Richard

Post Reply

Return to “Other networking topics”