Page 1 of 1

VPN creating but not woking

Posted: Tue May 07, 2019 6:34 pm
by riddleman
Hi everyone. I have a problem with vpn. I create ovpn connection via import from file for gitlab. VPN connection creating successfully and output message about successfully connected. But on gitlab page i retreive 404. On Ubntu, Debian and Archlinux I did not had any problems with it.
I tried reinstall network-manager-openvpn-gnome and network-manager-openvpn packages. Also installed network-manager-l2tp network-manager-l2tp-gnome packages. But it not help.

Re: VPN creating but not woking

Posted: Thu May 09, 2019 12:49 pm
by GELvdH
Howdy, I have 3 computers, 2 desktops with Win10/LM19.1 dual boot and a laptop with LM 19.1. I am running NordVpn on all of them and it runs great. It installs easily the cost is minimal (less than $3 per month on a 3year plan). NordVpn uses openvpn and you can (should) set it to tcp when you install it. Hope this helps.

Re: VPN creating but not woking

Posted: Thu May 09, 2019 3:43 pm
by phd21
Hi riddleman,

Welcome to the wonderful world of Linux Mint and its excellent forum!

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Who is your VPN provider? Can you provide a GitLab link for us to see?

Always use the secure VPN protocol "openVPN" or "WireGuard" (very new) if your VPN provider supports these instead of "l2tp" or pptp, etc...

FYI: To GELvdH and Everyone else regarding OpenVPN, the OpenVPN tech support and developers told me to always use UDP configurations (somewhere-udp.ovpn) whenever possible and only use the TCP configuration files (somewhere-tcp.ovpn) if the UDP is not working for you because of potential risk. I am not sure if the openVPN TCP "melt down" issue was resolved in openVPN software v2.4 or newer?

What is TCP Meltdown? | OpenVPN
https://openvpn.net/faq/what-is-tcp-meltdown/
Why does OpenVPN use UDP and TCP? | OpenVPN
https://openvpn.net/faq/why-does-openvp ... p-and-tcp/

TCP or UDP? Which Is better? | NordVPN
https://nordvpn.com/blog/tcp-or-udp-which-is-better/

TCP vs UDP: Understanding the Difference
https://www.vpnmentor.com/blog/tcp-vs-udp/
I recommend installing these packages below and restarting your computer before importing new openvpn connections.

Code: Select all

sudo apt install openresolv easy-rsa network-manager-openvpn bind9 unbound 
Here is a post with very good information

[SOLVED]How to fix dns leaks? - Page 2 - Linux Mint Forums
viewtopic.php?f=157&t=270477&hilit=openresolv&start=20


FYI: WireGuard VPN: What You Need to Know - NOT (Yet) Recommended
https://restoreprivacy.com/wireguard/

VPN Providers That Support WireGuard In 2019 - GreyCoder
https://greycoder.com/a-list-of-wiregua ... s-in-2019/

AzireVPN Review - Is This The Most Secure VPN? I Doubt. Here's Why...
https://thebestvpn.com/reviews/azirevpn/

Hope this helps ...

Re: VPN creating but not woking

Posted: Thu May 09, 2019 4:14 pm
by GELvdH
After watching the nordvpn video it confirms my feeling about using tcp. My internet connection is 100mb so speed is of little consequence but security is, my personal preference is for security. I understand that not everyone has such a high internet speed so it seems to boil down to personal desires and/or need. I am also running Megasync cloud so my system slows down somewhat because of the encryption, I think they said about 30per cent. Thanks for your info.

Re: VPN creating but not woking

Posted: Thu May 09, 2019 4:20 pm
by phd21
Hi GELvdH,

You are welcome...

I just finished updating my last reply with more information, please re-read it especially about the TCP "Meltdown".

Re: VPN creating but not woking

Posted: Thu May 09, 2019 5:22 pm
by GELvdH
Just tried both protocols and saw no difference in speed. After reading the meltdown article it looks like the UDP would be the better choice. Thanks again.
How is our openvpn questioner riddleman doing now?

Re: VPN creating but not woking

Posted: Thu May 09, 2019 5:39 pm
by phd21
Hi GELvdH,

You are welcome...again...

Here is a more current article on TCP vs UDP
OpenVPN - TCP or UDP tunneling? | Hamy - The IT Guy
https://hamy.io/post/0002/openvpn-tcp-or-udp-tunneling/

I guess we'll see when riddleman replies whether he's got his VPN server(s) working properly.

I too have many different VPN servers installed from various VPN providers and they all work well.