[SOLVED] Thunar, Samba and NetApp Appliances

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 6
Joined: Thu Jun 07, 2018 5:27 pm

[SOLVED] Thunar, Samba and NetApp Appliances

Post by tictactux » Fri Jun 28, 2019 4:06 am

This bugged me for quite some time - ever since Mint 19.1 I could not access some samba shares on NetApp appliances via Thunar. It's a known problem that NetApp appliances of a certain age don't like the SMB3_11 protocol. But all attempts to set "client max protocol = SMB3_10" in /etc/samba/smb.conf failed.
Today I found out that (at least in the XFCE edition), Thunar doesn't even attempt to read /etc/samba/smb.conf. But it does read ~/.smb/smb.conf! So just

Code: Select all

  client max protocol = SMB3_10
  client min protocol = SMB2
into ~/.smb/smb.conf and you're good to go. Alternatively, symlink /etc/samba/smb.conf to ~/.smb/smb.conf, but it takes longer to load shares, probably because there's much unneeded stuff in /etc/samba/smb.conf. So just these two lines should be good enough to get you connected.

Hope this helps, Ben

Post Reply

Return to “Other networking topics”