Nemo issue with SMB connected to Windows Share

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
harry_fine
Level 1
Level 1
Posts: 5
Joined: Sat Aug 17, 2019 2:38 pm

Nemo issue with SMB connected to Windows Share

Post by harry_fine » Sat Aug 17, 2019 3:00 pm

New to linux, but have latest version downloaded with Cinnamon desktop. Extremely impressed. Have smb and all its components and CIFS tools installed.

Made the changes everyone is talking about with max protocol = SMB2 and name resolve order = bcast lmhosts hosts wins

I managed to connect to my windows machine, which uses SMB2, and has the same Workgroup name. But I can't get there and browse clicking on Networks in Nemo. Only way it works is to go file --> Connect to server and then do Nemo's dialogue box with the share name, directory, user name, password, server name or IP.

When I do this, it successfully connects and puts an icon on the desktop with the share name and I can browse. Next I'm going to put this in my /etc/fstab so it mounts on boot.

OK, so here's the problem or weird thing. In Nemo, under networks, when I click it shows my linux laptop (that's machine I'm using), my Synology box, and when I click on it I get access to files/folders. And it also shows the Windows Workgroup name, and clicking on it gets the Windows MACHINE name, but clicking on the machine name it says Unable to Mount Location. Failed to retrieve share list.

So I get it, it's a machine not a share. But why can't I make the share I created show up under Networks using Nemo? Why do I have to use the file --> Connect to server dialogue every time unless I automount it? Is there no way to have the SMB browser see the Windows machine, click on it with Nemo and get the shares?

From the Windows side, I can click in the address bar \\HarryLaptop and it gives me shares on the Linux side. But if I do the same in Nemo, clicking smb://Landlord, it gives me the message Could not display smb://Landlord.

Hope I've been clear.

altair4
Level 19
Level 19
Posts: 9681
Joined: Tue Feb 03, 2009 10:27 am

Re: Nemo issue with SMB connected to Windows Share

Post by altair4 » Sat Aug 17, 2019 3:50 pm

Made the changes everyone is talking about with max protocol = SMB2 and name resolve order = bcast lmhosts hosts wins
No need to mess with "client max protocol" if you are using Mint 19.2. It's set to automatically negotiate with the server to find the best SMB dialect to use from SMB1 all the way up to SMB3 all by itself.
And it also shows the Windows Workgroup name, and clicking on it gets the Windows MACHINE name, but clicking on the machine name it says Unable to Mount Location. Failed to retrieve share list.
We talking about Windows 10 here. It's considered a bug https://bugs.launchpad.net/gvfs/+bug/1828107
OK, so here's the problem or weird thing. In Nemo, under networks, when I click it shows my linux laptop (that's machine I'm using), my Synology box, and when I click on it I get access to files/folders.
Because both Mint and Synology don't have to use NetBIOS which is the way Windows used to "discover" hosts on the network. Instead it uses mDNS ( avahi ) and it should resolve to a hostname.local type of hostname. If you had a MacBook in the mix it too would show up because it is using the same mDNS mechanism ( Bonjour in MacOS ).
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

harry_fine
Level 1
Level 1
Posts: 5
Joined: Sat Aug 17, 2019 2:38 pm

Re: Nemo issue with SMB connected to Windows Share

Post by harry_fine » Sat Aug 17, 2019 5:32 pm

How does one configure avahi?

altair4
Level 19
Level 19
Posts: 9681
Joined: Tue Feb 03, 2009 10:27 am

Re: Nemo issue with SMB connected to Windows Share

Post by altair4 » Sun Aug 18, 2019 8:05 am

You don't. It simply is.

Any Ubuntu system ( or something based on or forked from Ubuntu ) past 17.10 or so that has samba installed and avahi-daemon running will automatically announce it's presence to the rest of the network. All other Linux and MacOS systems will see that machine in their file managers unless avahi ( Linux ) or Bonjour ( MacOS ) has been disabled somehow on those systems.

The hold out is Windows. The mDNS process is alive and well in Win10 ( you can access a Linux machine by its mDNS hostname: \\linux-host-name.local ) but Win10 does not Discover others that way nor does it announce itself that way.

It's probably ego. Windows has its own mDNS like system called WS-Discovery ( WSD ) which it uses to broadcast and find other Win10 systems. But it's not compatible with avahi / bonjour. There is no client side WSD port in Linux but there is one for the server side: Windows 10 and Samba File Sharing
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”