19.2 can't connect to 19.1

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
steve-s
Level 1
Level 1
Posts: 4
Joined: Mon Oct 24, 2016 4:22 pm

19.2 can't connect to 19.1

Post by steve-s » Sun Aug 25, 2019 6:56 pm

I have 3 Machines that need to talk to each other.

Workstation - mint 19.2 - no min protocol set, allows SMB1
FreeeNAS - FreeNAS-11.1-U7 - min protocol = SMB2
Plex - smb.config modfied as shown below so it can talk to FreeNAS

Code: Select all

 under "workgroup =" add the following lines...
client min protocol = SMB2
client max protocol = SMB3
server min protocol = SMB2
server max protocol = SMB3
The issue started when I realized Plex could not mount through SMB to FreeNAS. Plex machine is new so it was always like this. After changes noted above were made, Plex now mounts to FreeNAS but stopped working to Workstation. Workstation can see the machine in Nemo but no longer connect. Running smbclient -L from Workstation to Plex results in

Code: Select all

Connection to 192.168.0.28 failed (Error NT_STATUS_IO_TIMEOUT)
All IPs are correct. I thought Samba in 19.2 changed the maximum client smb dialect that it can use from SMB1 to SMB3. Am I mixing up Samba and SMB? Still new to Linux (< 1 year). I must allow Workstation to use SMB1 as I still use my older D-Link DNS325s which can not be upgraded to SMB2+ (no thanks to the jackasses at DLink)

Any help is appreciated!
Steve

Post Reply

Return to “Other networking topics”