Teach me how to enable qname minimisation

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
fernandocabral
Level 2
Level 2
Posts: 56
Joined: Wed Jun 04, 2014 6:15 am

Teach me how to enable qname minimisation

Post by fernandocabral »

I have been using dnscrypt-proxy and protonvpn on Mint 19.3. They both seem to be working fine (some times I have some doubts about DNS and IP leaking...). Problem is, I can't make qname minimisation to work. When I run one of the commands bellow, I get the answer displayed:

Code: Select all

$ a.b.qnamemin-test.internet.nl.
"NO - QNAME minimisation is NOT enabled on your resolver :("

$ dig a.b.qnamemin-test.internet.nl TXT
[...]
;; ANSWER SECTION:
a.b.qnamemin-test.internet.nl. 10 IN	TXT	"NO - QNAME minimisation is NOT enabled on your resolver :("
Is there a command or a configuration file I must deal with to make it work?
User avatar
mikaelrask
Level 4
Level 4
Posts: 339
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Teach me how to enable qname minimisation

Post by mikaelrask »

hey, check this thread out it might can help you

https://discourse.pi-hole.net/t/unbound ... n/10038/11 have you installed the necessary packages?

according that thread it feels that it might work 50% of the times.

meby if your consern about network security in your router meaby a good ide is to check for an vpn, you could cahnce your dns in the router to google for better security and speed.

https://developers.google.com/speed/public-dns

good luck
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.54-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 20
Kernel 5,4.0.54-generic
Ram 4 gb
Post Reply

Return to “Other networking topics”