UFW Woes

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Elmer Fudd III
Level 1
Level 1
Posts: 3
Joined: Mon Jan 27, 2020 11:42 am

UFW Woes

Post by Elmer Fudd III »

On 19.3 with all current updates. About a week ago, I logged in and wasn't able to connect to the internet of even to local devices on the internet. I of course blamed the internet connection and reset the router and modem. Still nothing. Screwed around trying to get a UI connection to my router when I finally booted into windows and everything was fine. That's not good. Started looking on line and there seems to be some problems with UFW. Okay, I purged firewall-persistent, and disabled UFW. Everything now works. Alright, that's progress. Log out, log back in, nothing works until I again 'sudo UFW disable', even though it says it will stop reactivation on subsequent startup. Tried living with UFW by adding the local network using rules, but still no go. The only way that LM is usable right now is to disable UFW each and every time I startup. I don't have a problem living without UFW, but it seems extremely persistent.

What changed (new kernel?); why is this happening?

rene
Level 14
Level 14
Posts: 5041
Joined: Sun Mar 27, 2016 6:58 pm

Re: UFW Woes

Post by rene »

Try

Code: Select all

$ sudo systemctl stop ufw
$ sudo systemctl disable ufw

Elmer Fudd III
Level 1
Level 1
Posts: 3
Joined: Mon Jan 27, 2020 11:42 am

Re: UFW Woes

Post by Elmer Fudd III »

Thanks for your quick response. Any idea if they'll get UFW working? If not is their an alternative local machine firewall that does work?

rene
Level 14
Level 14
Posts: 5041
Joined: Sun Mar 27, 2016 6:58 pm

Re: UFW Woes

Post by rene »

A local firewall tends to be completely irrelevant on Linux; am afraid I couldn't care less about ufw.

Elmer Fudd III
Level 1
Level 1
Posts: 3
Joined: Mon Jan 27, 2020 11:42 am

Re: UFW Woes

Post by Elmer Fudd III »

Irrelevant, sounds good. Won't worry about ufw.
On an interesting side note 'sudo systemctl disable ufw' did not disable ufw on future restarts. I still have to do a 'sudo ufw disable' at the start of each session. Tried to do a 'sudo apt purge ufw' and that was a foolish - nothing worked, even after a reboot. So I reinstalled ufw and am continuing with the 'sudo ufw disable'. At his point the only thing I can believe is that a long series of distribution upgrades have caught up with me (went from 18 to 19 series without fresh installs). I'll install mx linux (stability) over on another partition, move my files, and do a fresh install of mint. Seems to be the only option left.
Thanks all.

Post Reply

Return to “Other networking topics”