Page 1 of 1

Firewall GUI (gufw) bugs

Posted: Wed Jul 01, 2020 6:59 am
by powerhouse
The gufw used to be a nice tool to configure the firewall. But in recent years it gives me headaches.

Let's say I want to configure ssh and limit access to the local net (192.168.1.0/24):

Choose SSH from the preconfigured list, then press the right arrow in the bottom right corner of the windows to go to "Advanced" configuration.

What do I get? Greyed out From and To IP address fields. A [paste] button is right next, but that will paste my own IP @#$%&*@! Either pasting the IP or not will NOT allow me to edit the IP!!

What's wrong with gufw?

Conversely, if I start configuring using the "Simple" option, then go to "Advanced", it kinda works. "Kinda" because it remembers my last configuration attempt which can screw up everything. Using this method got me an "immutable" error when I tried to delete the configuration. Had to close and restart gufw to delete.

Note: I run gufw as superuser.

P.S.: I filed a bug report at github.

Re: Firewall GUI (gufw) bugs

Posted: Sat Jul 11, 2020 6:12 am
by powerhouse
Just to let the readers know: The developer contacted me within hours of filing the bug report to ask for a screenshot. Kudos!

I love open source software and the great support you get with it!

Will update when I hear more.